www-infrastructure-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "#asfinfra IRC Bot (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (INFRA-4881) need cmake on build machines
Date Tue, 05 Jun 2012 00:49:23 GMT

     [ https://issues.apache.org/jira/browse/INFRA-4881?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

#asfinfra IRC Bot closed INFRA-4881.
------------------------------------

    Resolution: Fixed
    
> need cmake on build machines 
> -----------------------------
>
>                 Key: INFRA-4881
>                 URL: https://issues.apache.org/jira/browse/INFRA-4881
>             Project: Infrastructure
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>            Reporter: Colin Patrick McCabe
>
> The cmake program needs to be installed on all Apache Jenkins and other build machines.
 This build dependency was introduced by HADOOP-8368.
> Otherwise, you get errors like this when trying to build the native components of Hadoop:
> {code}
> Caused by: <https://builds.apache.org/job/Hadoop-Common-trunk/ws/trunk/hadoop-common-project/hadoop-common/target/antrun/build-main.xml>:4:
Execute failed: java.io.IOException: Cannot run program "cmake" (in directory "<https://builds.apache.org/job/Hadoop-Common-trunk/ws/trunk/hadoop-common-project/hadoop-common/target/native")>:
java.io.IOException: error=2, No such file or directory
>        at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:679)
>        at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:502)
>        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
>        at sun.reflect.GeneratedMethodAccessor123.invoke(Unknown Source)
>        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>        at java.lang.reflect.Method.invoke(Method.java:597)
>        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
>        at org.apache.tools.ant.Task.perform(Task.java:348)
>        at org.apache.tools.ant.Target.execute(Target.java:390)
>        at org.apache.tools.ant.Target.performTasks(Target.java:411)
>        at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1397)
>        at org.apache.tools.ant.Project.executeTarget(Project.java:1366)
>        at org.apache.maven.plugin.antrun.AntRunMojo.execute(AntRunMojo.java:270)
>        ... 21 more
> Caused by: java.io.IOException: Cannot run program "cmake" (in directory "<https://builds.apache.org/job/Hadoop-Common-trunk/ws/trunk/hadoop-common-project/hadoop-common/target/native")>:
java.io.IOException: error=2, No such file or directory
>        at java.lang.ProcessBuilder.start(ProcessBuilder.java:460)
>        at java.lang.Runtime.exec(Runtime.java:593)
>        at org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:827)
>        at org.apache.tools.ant.taskdefs.Execute.launch(Execute.java:445)
>        at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:459)
>        at org.apache.tools.ant.taskdefs.ExecTask.runExecute(ExecTask.java:635)
>        at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:676)
>        ... 33 more
> Caused by: java.io.IOException: java.io.IOException: error=2, No such file or directory
>        at java.lang.UNIXProcess.<init>(UNIXProcess.java:148)
>        at java.lang.ProcessImpl.start(ProcessImpl.java:65)
>        at java.lang.ProcessBuilder.start(ProcessBuilder.java:453)
>        ... 39 more
> [ERROR]
> [ERROR]
> [ERROR] For more information about the errors and possible solutions, please read the
following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
> [ERROR]
> [ERROR] After correcting the problems, you can resume the build with the command
> [ERROR]   mvn <goals> -rf :hadoop-common
> {code}
> Any version of cmake higher than or equal to cmake 2.6 should suffice.  (The exact version
doesn't matter as long as it's at least 2.6.)  A suitable version is probably only an "apt-get"
or "yum install" away.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message