www-infrastructure-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Demers (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (INFRA-4482) Why is my upload to mvn spread across multiple repositories?
Date Wed, 29 Feb 2012 18:55:56 GMT

    [ https://issues.apache.org/jira/browse/INFRA-4482?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13219408#comment-13219408
] 

Brian Demers commented on INFRA-4482:
-------------------------------------

It looks like your outbound connection keeps getting a different IP.  Can you verify this
is how your network is setup?
                
> Why is my upload to mvn spread across multiple repositories?
> ------------------------------------------------------------
>
>                 Key: INFRA-4482
>                 URL: https://issues.apache.org/jira/browse/INFRA-4482
>             Project: Infrastructure
>          Issue Type: Task
>      Security Level: public(Regular issues) 
>          Components: Nexus
>            Reporter: stack
>         Attachments: Screen Shot 2012-02-23 at 9.50.58 AM.png
>
>
> I'm been struggling publishing a release to repository.apache.org.  Its worked for me
in the past.  If you look at https://repository.apache.org/index.html#stagingRepositories
(you need to be logged in), you will see that I somehow made twelve repositories when I did
my mvn release:perform, each artifact element to its own repo.  Any idea how that happens?
 (I'll attach a png that shows similar).  How do I prevent it?
> I have another issue where the upload to apache will fail with a 400 Bad Request very
frequently uploading one of my artifact items -- usually maven-metadata.xml -- but then, just
now, it went through fine.  Pointers appreciated on this little nugget too.
> I'm using mvn 3.0.4 and 2.2.2 of the maven:release plugin.  Otherwise, my settings.xml
is one that has worked for me in the past:
> {code}
>   <servers>
>     <!-- To publish a snapshot of some part of Maven -->
>     <server>
>       <id>apache.snapshots.https</id>
>       <username>stack
>       </username>
>       <password>XXXX
>       </password>
>     </server>
>     <!-- To publish a website using Maven -->
>     <!-- To stage a release of some part of Maven -->
>     <server>
>       <id>apache.releases.https</id>
>       <username>stack
>       </username>
>       <password>XXXX
>       </password>
>     </server>
>   </servers>
>   <profiles>
>     <profile>
>       <id>apache-release</id>
>       <properties>
>     <gpg.keyname>00A5F21E</gpg.keyname>
>     <gpg.passphrase>XXXX
>     </gpg.passphrase>
>       </properties>
>     </profile>
>   </profiles>
> </settings>
> {code}
> My pom is here: http://svn.apache.org/viewvc/hbase/tags/0.92.0mvn/pom.xml?view=markup
> Thanks for any pointers.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message