www-infrastructure-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gavin (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (INFRA-3535) Add "coverage" step to the libcloud buildbot
Date Sat, 26 Mar 2011 01:37:05 GMT

    [ https://issues.apache.org/jira/browse/INFRA-3535?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13011535#comment-13011535
] 

Gavin commented on INFRA-3535:
------------------------------

Sorry, can you work to a 2.85 version of coverage. Anything above that on the ubuntu 10.4.2
does not install. I've tries manual installs, pip install, easy_install on all versions above
2.8.5 and none of them build. As we stick to LTS Ubuntu releases it will be another year before
we upgrade the OS.

> Add "coverage" step to the libcloud buildbot
> --------------------------------------------
>
>                 Key: INFRA-3535
>                 URL: https://issues.apache.org/jira/browse/INFRA-3535
>             Project: Infrastructure
>          Issue Type: Task
>      Security Level: public(Regular issues) 
>            Reporter: Tomaz Muraus
>            Priority: Minor
>
> It would be great if you could add another step to the libcloud builder.
> The build step should run the following command: "python setup.py coverage".
> This command generates a bunch of HTML files (test coverage) inside the "coverage_html_report"
directory which should be copied to some publicly accessible place (for example http://ci.apache.org/projects/libcloud/coverage/).
> This step also requires python coverage package to be installed on the server.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message