www-infrastructure-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sam Ruby <ru...@intertwingly.net>
Subject Re: [whimsy] roster/committee annotations don't always appear
Date Tue, 20 May 2014 01:06:33 GMT
On Mon, May 19, 2014 at 7:33 PM, sebb <sebbaz@gmail.com> wrote:
> Just gone wrong again, and still went wrong (once) when I retried with
> the network debug:
>
> GET https://whimsy.apache.org/roster/json/info   =>  [HTTP/1.1 500
> Internal Server Error 224ms]

That's helpful.  I was able to match that with the following entry in
the server log:

App 21194 stderr: _ERROR #<NoMethodError: undefined method `id' for
nil:NilClass>

The line cited contains "chair: committee.chair.id".  I don't yet know
why committee.chair would be nil, and certainly don't know why it
would SOMETIMES be nil, but I will modify this line to prevent the
script from blowing up should this occur.

> Worked when I retried again, but now I get the following, which does
> not seem to affect the display:
>
> "Error: [$rootScope:infdig]
> http://errors.angularjs.otrg/1.2.14/$rootScope/infdig?p0 ...

You are correct that this is not a problem.  A rough analogy:
Angular.js is like a spreadseet... a change in one cell can cause
another cell to be updated, which can cause other cell(s) to be
updated.  Angular.js is like that, but based on asynchronous events.
My script makes a number of asynchronous requests and the web page is
updated as the data arrives.  Depending on timing, Angular.js may
conclude that there is an infinite loop as the page updates don't seem
to be settling down.

- Sam Ruby

> On 18 May 2014 18:56, sebb <sebbaz@gmail.com> wrote:
>> On 17 May 2014 02:07, Sam Ruby <rubys@intertwingly.net> wrote:
>>> On Fri, May 16, 2014 at 8:14 PM, sebb <sebbaz@gmail.com> wrote:
>>>> The annotations on the RHS of the committee pages don't always seem to appear.
>>>>
>>>> For example, cordova sometimes does not show any "not in LDAP"
>>>> entries, and currently is not showing the chair entry.
>>>
>>> Can you enable tools=>web developer=>network and re-request the page?
>>>
>>> Do you see any failures?  In particular, does the get of "info" fail?
>>> Does the *second* get of "ldap" fail?
>>>
>>> If you don't see anything obviously amiss, can you capture a
>>> screen-shot including the network info?
>>
>> Of course when I tried just now, everything worked fine.
>> Will report back with details if I get another failure.
>>
>>>> The classic version works OK.
>>>>
>>>> [This is using Firefox on MacOS]
>>>
>>> - Sam Ruby

Mime
View raw message