www-infrastructure-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tony Stevenson <t...@pc-tony.com>
Subject Re: SVN + baseline errors revisited
Date Fri, 18 Sep 2009 13:12:39 GMT

On 18 Sep 2009, at 13:59, Werner Punz wrote:

> Hello everyone since no one answered the first time. I will repost  
> it again, with additional information

What additional information?  Can you show us some example errors, so  
we can, ehrrm, not just guess?  :-)

>
> I seem to have some kind of lag problem here with both  
> svn.apache.org or svn.eu.apache.org
>
> The problem seems to be that I am getting baseline errors after a  
> commit which resolve themselves after a few seconds.

If you commit against the EU server, it proxies that commit back to  
the US (master) and then then form there the commit is replayed back  
to the EU server.
If there are large commits this can cause lag, and hang-ups.  There  
isnt a great deal we can do about that.  That's just what we have (for  
now).

> I have not tried older svn versions other than what I have on my  
> machine currently (1.6.5) but the problem is rather annoying.
> The baseline error seems to go away after a handful of seconds like  
> it seems to me that some date on the svn server itself needs some  
> catch up to do (probably a sync lag) before being in sync again (my  
> machine is cnnected to a time server, but since svn seems to rely on  
> version numbers I doubt this is a an issue here).
>

Your right, it is nothing to to do with time, just the revision numbers.




Cheers,
Tony


--------------------------------------------
Tony Stevenson

tony@pc-tony.com - pctony@apache.org
pctony@freenode.net - tony@caret.cam.ac.uk

http://blog.pc-tony.com

1024D/51047D66 ECAF DC55 C608 5E82 0B5E
3359 C9C7 924E 5104 7D66
--------------------------------------------






Mime
View raw message