www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte" <rfscho...@apache.org>
Subject Re: Deprecated versions Maven/Ant/Java to be removed soon.
Date Mon, 07 Oct 2019 20:10:12 GMT
On Mon, 07 Oct 2019 21:49:44 +0200, Tilman Hausherr  
<THausherr@t-online.de> wrote:

> Am 07.10.2019 um 12:39 schrieb Gavin McDonald:
>> Please find below a summary of each; and links to their cwiki  
>> documentation
>> page. Any questions please let me know.
>>
>> Thanks
>>
>> Gav...
>>
>> [Maven]
>>
>> 3.0.4 (3.0.5 available)
>> 3.2.1 (3.2.5 available)
>> 3.3.3 (3.3.9 available)
>> 3.5.0, 3.5.2 (3.5.4 available)
>> 3.6.0, 3.6.1 (3.6.2 available)
>
> This is sad... I have a maven build

Makes sense to me.

>
> https://builds.apache.org/view/P/view/PDFBox/job/PDFBox-2.0.x-jdk6/
>
> that runs on jdk8 but uses jdk6 javac (with fork) and it works with  
> 3.5.2, 3.5.0 and 3.2.1 only. With other maven versions, it aborts in the  
> maven-compiler-plugin without any details.

Can't find a reason why it only works with these versions, there should be  
no relation between the Maven version and the maven-compiler-plugin. Might  
be worth investigating.

Robert

>
> That build job is not THAT important, but it helps us to make sure that  
> the sources still build on jdk6.
>
> Tilman

Mime
View raw message