www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Barboni" <sk...@apache.org>
Subject RE: Missing maven installations
Date Tue, 24 Sep 2019 14:02:22 GMT
Hi, 
 is there an "official" list of infra approved tools like ant or maven so we can  refer too
? 
 
 After patching to latest point release it worked fine. Thanks for info.

Regards

Eric

-----Message d'origine-----
De : Gavin McDonald <ipv6guru@gmail.com> 
Envoyé : vendredi 20 septembre 2019 19:28
À : builds <builds@apache.org>
Objet : Re: Missing maven installations

Hi,

On Fri, Sep 20, 2019 at 5:59 PM Tilman Hausherr <THausherr@t-online.de>
wrote:

> Surprisingly, it worked with 3.5.4 this time. Twice. Very mysterious.
>
> Btw if 3.5.2 is not installed, then why is it available in the Jenkins 
> configuration?
>

There are still nodes that are yet to be upgraded, as we are in a transition period where
older nodes still have this installed.

HTH

Gav...


> Tilman
>
> Am 20.09.2019 um 18:09 schrieb Tilman Hausherr:
> > I used 3.5.2 for a jdk6 compile (this is to make sure that our 
> > software still works on jdk6), I tried with 3.5.4 and (from memory) 
> > it failed without giving me an error message.
> >
> > https://builds.apache.org/job/PDFBox-2.0.x-jdk6/
> >
> > I'll try again...
> >
> > Tilman
> >
> > Am 20.09.2019 um 14:43 schrieb Gavin McDonald:
> >> As nodes have been upgraded to Ubuntu 18.04 LTS it was decided to 
> >> only install the latest point releases for Ant, Maven and Java. So 
> >> the latest 3.2.x, 3.5.x etc.
> >>
> >> Therefore, can you please explain why 3.2.1 is needed as opposed to
> >> 3.2.5
> >> that is installed, and
> >> why 3.5.2 is needed, as opposed to 3.5.4 which is installed etc
> >>
> >> Thanks
> >>
> >> Gav...
> >>
> >>
> >> On Fri, Sep 20, 2019 at 7:59 AM Tilman Hausherr 
> >> <THausherr@t-online.de>
> >> wrote:
> >>> Am 19.09.2019 um 15:41 schrieb Eric Barboni:
> >>>> Ahoy,
> >>>>
> >>>>    Getting issue forrr maven 3.5.2 on H28 and H23
> >>> My current list now has H50, H24, H48, H49, H27, H22, H44
> >>>
> >>> Tilman
> >>>
> >>>
> >>>>    Rrregarrrds
> >>>>
> >>>> Eric
> >>>>
> >>>>
> >>>> -----Message d'origine-----
> >>>> De : Tilman Hausherr <THausherr@t-online.de> Envoyé : samedi
7 
> >>>> septembre 2019 15:43 À : builds@apache.org Objet : Re: Missing 
> >>>> maven installations
> >>>>
> >>>> ERROR: Maven Home /home/jenkins/tools/maven/apache-maven-3.5.2 
> >>>> doesnt
> >> exist
> >>>> On H48, H24, H50
> >>>>
> >>>> ERROR: Maven Home /home/jenkins/tools/maven/apache-maven-3.5.0 
> >>>> doesnt
> >> exist
> >>>> On H50
> >>>>
> >>>> In the past weeks.
> >>>>
> >>>> (Didn't want to be the first to complain this time)
> >>>>
> >>>> Tilman
> >>>>
> >>>>
> >>>> Am 07.09.2019 um 15:30 schrieb Markus Schuch:
> >>>>> Hi,
> >>>>>
> >>>>> it seems, that on some nodes the maven installations are not 
> >>>>> properly rolled out:
> >>>>>
> >>>>> We encountered
> >>>>>
> >>>>> FATAL: Couldn?t find any executable in
> >>>>> /home/jenkins/tools/maven/apache-maven-3.2.1
> >>>>>
> >>>>> on nodes H25, H26 and H27.
> >>>>>
> >>>>> Example:
> >>>>> https://builds.apache.org/view/All/job/ManifoldCF-mvn/725/
> >>>>>
> >>>>> The Job configuration refers to maven-3.2.1 which should be 
> >>>>> available according to
> >>>>>
> https://cwiki.apache.org/confluence/display/INFRA/Maven+Installation+M
> >>>>>
> >>>>> atrix
> >>>>>
> >>>>> Can you please help us to provide the maven installation?
> >>>>>
> >>>>> Many thanks in advance
> >>>>> Markus
> >>>>
> >>
> >> --
> >> Gav...
> >>
> >
>
>

--
Gav...


Mime
View raw message