www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: Configuring build with maven 3.3.9
Date Mon, 25 Sep 2017 20:54:41 GMT
nevermind - fixed by upgrading maven invoker plugin to current version, which
doesn't use mvn.bat.

Apologies for the noise.  -Marshall Schor


On 9/21/2017 4:07 PM, Marshall Schor wrote:
> ping? we're continuing to get this on Windows builds.
>
> latest one:
>
> <https://builds.apache.org/job/UIMA-v3-sdk/238/display/redirect?page=changes>
>
> -Marshall
>
>
> On 9/19/2017 3:28 PM, Marshall Schor wrote:
>> Hi,
>>
>> Looks like there still may be a small issue. 
>> Running our build on a Windows system now starts and runs, until it gets to an
>> "integration test".
>>
>>   The integration test runs 'maven within maven"; we use it to test new maven
>> plugins. 
>>   This test fails with the message:
>>      Maven invocation failed. Error configuring command-line. 
>>      Reason: Maven executable not found at:
>>        F:\jenkins\tools\maven\apache-maven-3.3.9\bin\mvn.bat
>>
>> Any ideas on how to fix this?
>>
>> -Marshall Schor
>>
>>
>> On 9/19/2017 9:27 AM, Marshall Schor wrote:
>>> Thanks, Gav!
>>>
>>> That seemed to do the trick...
>>>
>>> -Marshall
>>>
>>>
>>> On 9/14/2017 6:28 PM, Gav wrote:
>>>> Hi,
>>>>
>>>> All of the 'Latest' options for 'Ant,Maven'Java' etc are configured to work
>>>> for both Linux and Windows, have been for a while.
>>>>
>>>> Maven 3.3.9 used to be 'Latest' until 3.5.0 was released when that took
>>>> over the symlinking for Latest.
>>>>
>>>> So 3.3.9 used to work for both, then stopped.
>>>>
>>>> As there are still a few jobs using 3.3.9 , I have created a tool location
>>>> on the Windows nodes for 3.3.9 so your builds
>>>> should now 'just work' by choosing 'Maven 3.3.9'
>>>>
>>>> Give it a whirl and let me know.
>>>>
>>>> Gav...
>>>>
>>>>
>>>> On Fri, Sep 15, 2017 at 6:02 AM, Marshall Schor <msa@schor.com> wrote:
>>>>
>>>>> Hi,
>>>>>
>>>>> We have a build which needs maven 3.3.9.
>>>>>
>>>>> I see in the Jenkins pulldown menu for configuring builds, there are
2
>>>>> picks for
>>>>> maven 3.3.9:
>>>>>
>>>>>   - one is labeled "Maven 3.3.9"
>>>>>
>>>>>   - one is labeled "Maven 3.3.9 (Windows)"
>>>>>
>>>>>
>>>>> We are using the first ("Maven 3.3.9").  Our build is not set to restrict
>>>>> where
>>>>> it can be run.
>>>>>
>>>>> So, when it runs on a windows machine, it fails, saying it can't find
>>>>> Maven 3.3.9.
>>>>>
>>>>> ---------------------
>>>>>
>>>>> Do you require all builds which need this Maven, to have 2 configurations,
>>>>> one
>>>>> with the (Windows) pick, restricted to Windows machine, and the other
>>>>> without
>>>>> that, for Linux boxes?
>>>>>
>>>>> We would of course prefer not to have to duplicate our build configurations
>>>>> because of this - so if there's another better way, please let us know.
>>>>>
>>>>> Thanks. -Marshall
>>>>>
>>>>>
>


Mime
View raw message