www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ismael Juma <ism...@juma.me.uk>
Subject Re: Deprecated JDKs being removed from Jenkins soon.
Date Sun, 24 Sep 2017 08:52:16 GMT
Thanks for the quick response. Seems like it was H25:

https://builds.apache.org/job/kafka-trunk-jdk9/57/

Ismael

On Sun, Sep 24, 2017 at 9:19 AM, Gavin McDonald <gavin@16degrees.com.au>
wrote:

>
> > On 24 Sep 2017, at 5:47 pm, Ismael Juma <ismael@juma.me.uk> wrote:
> >
> > Hi Gavin,
> >
> > To avoid running into problems when 9-b181 is removed, I changed Apache
> > Kafka's Jenkins jobs to use JDK 1.9 (latest) (which is what we do for
> Java
> > 7 and Java 8) and got:
> >
> > ERROR: JAVA_HOME is set to an invalid directory:
> > /home/jenkins/tools/java/latest1.9
> >
> >
> > Is the roll out of the final JDK 9 still in progress?
>
> I spot checked on a few Jenkins slaves, can you tell me which one you
> failed on?
>
> Thanks
>
> Gav…
>
>
> gmcdonald@asf927:~$ /home/jenkins/tools/java/latest1.9/bin/java -version
> java version "9"
> Java(TM) SE Runtime Environment (build 9+181)
> Java HotSpot(TM) 64-Bit Server VM (build 9+181, mixed mode)
>
> gmcdonald@asf914:~$ /home/jenkins/tools/java/latest1.9/bin/java -version
> java version "9"
> Java(TM) SE Runtime Environment (build 9+181)
> Java HotSpot(TM) 64-Bit Server VM (build 9+181, mixed mode)
>
> gmcdonald@asf910:~$ /home/jenkins/tools/java/latest1.9/bin/java -version
> java version "9"
> Java(TM) SE Runtime Environment (build 9+181)
> Java HotSpot(TM) 64-Bit Server VM (build 9+181, mixed mode)
>
> gmcdonald@asf900:~$ /home/jenkins/tools/java/latest1.9/bin/java -version
> java version "9"
> Java(TM) SE Runtime Environment (build 9+181)
> Java HotSpot(TM) 64-Bit Server VM (build 9+181, mixed mode)
>
>
> >
> > Thanks,
> > Ismael
> >
> > On Sun, Sep 24, 2017 at 8:10 AM, Gavin McDonald <gavin@16degrees.com.au>
> > wrote:
> >
> >> Hi All,
> >>
> >> As advertised on https://cwiki.apache.org/confluence/display/INFRA/JDK+
> >> Installation+Matrix , we will
> >> be removing some older JDK releases from Jenkins.
> >>
> >> 1.8.0_92, 1.8.0_102, 9-b128, 9-b132, 9-b139, 9-b142 will all be removed
> >> within the next few days.
> >>
> >> Should your builds be using any of these, please migrate to a later
> >> version of JDK 1.8 or 9.
> >>
> >> Thanks
> >>
> >> Gav… (ASF Infra Team)
> >>
> >>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message