www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: [Fwd: Build failed in Jenkins: httpcomponents-client-5.x #113]
Date Tue, 01 Aug 2017 12:16:44 GMT
I've just tried forcing the build to use ubuntu; that has fixed the Maven issue.

Looks like windows-2012-2 does not have the correct Maven setup.

I'll raise a JIRA

On 1 August 2017 at 11:44, sebb <sebbaz@gmail.com> wrote:
> On 1 August 2017 at 11:32, Oleg Kalnichevski <olegk@apache.org> wrote:
>> Folks
>>
>> Could you please help me deal with a build failure I am seeing. It
>> appears to be related to Maven 3.3.9 not being at the expected
>> location. The problem looks non-intermittent. However all other build
>> jobs that make use of Maven 3.3.9 run just fine.
>>
>> Please help me understand if this is a mis-configuration on my part or
>> a mis-configured node the build job keeps on hitting over and over
>> again.
>>
>> Thank you in advance
>>
>> Oleg
>>
>> -------- Forwarded Message --------
>> From: Apache Jenkins Server <jenkins@builds.apache.org>
>> Reply-to: "HttpComponents Project" <dev@hc.apache.org>
>> To: commits@hc.apache.org
>> Subject: Build failed in Jenkins: httpcomponents-client-5.x #113
>> Date: Tue, 1 Aug 2017 10:00:18 +0000 (UTC)
>>
>> See <https://builds.apache.org/job/httpcomponents-client-5.x/113/displa
>> y/redirect>
>>
>> ------------------------------------------
>> Started by user olegk
>> [EnvInject] - Loading node environment variables.
>> Building remotely on windows-2012-2 (Windows) in workspace <https://bui
>> lds.apache.org/job/httpcomponents-client-5.x/ws/>
>>  > git rev-parse --is-inside-work-tree # timeout=10
>> Fetching changes from the remote Git repository
>>  > git config remote.origin.url https://git-wip-us.apache.org/repos/asf
>> /httpcomponents-client.git # timeout=10
>> Fetching upstream changes from https://git-wip-us.apache.org/repos/asf/
>> httpcomponents-client.git
>>  > git --version # timeout=10
>>  > git fetch --tags --progress https://git-wip-us.apache.org/repos/asf/
>> httpcomponents-client.git +refs/heads/*:refs/remotes/origin/*
>>  > git rev-parse "refs/remotes/origin/master^{commit}" # timeout=10
>>  > git rev-parse "refs/remotes/origin/origin/master^{commit}" #
>> timeout=10
>> Checking out Revision 888cefb7cd39cff379321096e1c2519d6adbe93c
>> (refs/remotes/origin/master)
>> Commit message: "[HTTPCLIENT-1858] Clone some code from Log4j 2 to
>> cache a StringBuilder in a ThreadLocal. Update to use the
>> StringBuilder's capacity instead of its length to measure upper bound."
>>  > git config core.sparsecheckout # timeout=10
>>  > git checkout -f 888cefb7cd39cff379321096e1c2519d6adbe93c
>>  > git rev-list 888cefb7cd39cff379321096e1c2519d6adbe93c # timeout=10
>> ERROR: Maven Home \home\jenkins\tools\maven\apache-maven-3.3.9 doesnt
>> exist
>
> The Maven installation matrix is here:
>
> https://cwiki.apache.org/confluence/display/INFRA/Maven+Installation+Matrix
>
> so there should be a 3.3.9 on Windows.
>
> I think fixing this probably needs INFRA help as the config does not
> seem to do anything unusual that might cause this.

Mime
View raw message