www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gav <gmcdon...@apache.org>
Subject Re: Jenkins Ant Matrix - and consolidating of versions.
Date Mon, 08 Aug 2016 00:49:27 GMT
Thanks Patrick,

For your Windows builds, look for Windows in the drop down, e.g please use
'Ant (latest Windows)' instead of 'Ant (latest).

HTH

Gav...


On Mon, Aug 8, 2016 at 10:25 AM, Patrick Hunt <phunt@apache.org> wrote:

> Thanks for the reminder Gavin, I moved the ZooKeeper jobs you listed to
> the latest version of Ant (we shouldn't really be dependent on any
> particular version afaik).
>
> Patrick
>
> On Sun, Aug 7, 2016 at 4:56 PM, Gav <gmcdonald@apache.org> wrote:
>
>> Hi Again,
>>
>> The only reply so far has been from Stefan regarding the cloud nodes.
>>
>> Please see again this page:-
>>
>> https://cwiki.apache.org/confluence/display/INFRA/Ant+Installation+Matrix
>>
>> Tomorrow is the day that 8 versions of Ant will be removed.
>>
>> These project jobs have failed to be migrated so far and will break :-
>>
>> v1.9.3
>> =====
>>
>> etch-trunk-windows-x86
>> etch-trunk-windows-x86-experimental
>>
>> v1.8.4
>> =====
>>
>> Derby-trunk-suites.All-ARM*
>> JMeter-Windows
>> Openmeetings 3.0.x
>> Pivot-maintenance
>> Pivot-maintenance on Java 7
>> Pivot-trunk
>> Pivot-trunk on Java 7
>> POI-with-old-Xerces
>> river-2.2-qa-jdk7
>> river-2.2-qa-win
>> river-discoveryTests
>> river-qa-refactor-arm
>> river-qa-refactor-j9-please-dont-abort-if-under-20hours
>> River-qa-refactor-jtreg
>>
>> v1.8.3
>> =====
>>
>> OpenMeetings ATutor Plugin
>> OpenMeetings Bitrix Plugin
>> OpenMeetings Moodle Plugin
>> OpenMeetings Teambox Plugin
>> OpenMeetings Zimbra Plugin
>>
>> v1.8.2
>> =====
>>
>> core-integration-testing-maven-3
>> core-integration-testing-maven-3-jdk-1.6-windows
>> core-integration-testing-maven-3-osx
>> core-integration-testing-maven-3-solaris
>> Lucene-Artifacts-6.x
>> Lucene-Artifacts-master
>> Lucene-Solr-Clover-6.x
>> Lucene-Solr-Clover-master
>> Lucene-Solr-Maven-6.x
>> Lucene-Solr-Maven-master
>> Lucene-Solr-NightlyTests-6.x
>> Lucene-Solr-NightlyTests-master
>> Lucene-Solr-SmokeRelease-6.0
>> Lucene-Solr-SmokeRelease-6.1
>> Lucene-Solr-SmokeRelease-6.x
>> Lucene-Solr-SmokeRelease-master
>> Lucene-Solr-Tests-5.5-Java7
>> Lucene-Solr-Tests-5.5-Java8
>> Lucene-Solr-Tests-6.x
>> Lucene-Solr-Tests-master
>> Lucene-Tests-MMAP-master
>> Pig on Spark Precommit Test
>> Pig-spark
>> Pig-trunk
>> Solr-Artifacts-6.x
>> Solr-Artifacts-master
>> Sqoop-hadoop100
>> Sqoop-hadoop200
>> Sqoop-hadoop20
>> Sqoop-hadoop23
>> Tomcat-7.x
>> ZooKeeper_branch34_solaris
>> ZooKeeper_branch34-WinVS2008_java
>> ZooKeeper-trunk-WinVS2008
>> ZooKeeper-trunk-WinVS2008_java
>>
>> v1.7.0
>> =====
>>
>> ZooKeeper_branch33_solaris
>>
>>
>>
>> On Tue, Aug 2, 2016 at 9:57 AM, Gav <gmcdonald@apache.org> wrote:
>>
>>> Hi All,
>>>
>>> Following on from my recent JDK and Maven emails, here is the remaining
>>> one we
>>> need to go through, that of Ant. Please find the Matrix of currently
>>> installed versions
>>> at :-
>>>
>>> https://cwiki.apache.org/confluence/display/INFRA/Ant+Installation+Matrix
>>>
>>>
>>>
>>> You will see we have one drop down item labelled 'Ant (latest)' -
>>> currently symlinked to the
>>> very latest 1.9.7 release. We also have versions 1.9.4 and 1.8.4
>>> installed and managed via
>>> puppet.
>>>
>>> I think that is as far back as we need to go. I intend to drop all
>>> auto-installed versions 7 days
>>> from now. So please migrate away from auto-install versions 1.6.5,
>>> 1.7.0, 1.7.1, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.9.3.
>>>
>>> I hope you agree that this consolidation of versions of all these tools
>>> will simplify choices, make them more accurate with what you expect.
>>>
>>> Any follow up questions please direct your email replies to the builds@
>>> mailing list.
>>>
>>> Thanks!
>>>
>>> Gav...
>>>
>>>
>>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message