www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dominik Stadler <dominik.stad...@gmx.at>
Subject Re: Jenkins Ant Matrix - and consolidating of versions.
Date Tue, 09 Aug 2016 15:46:43 GMT
Hm, still failing on ubuntu3 with "Ant 1.8.4", see
https://builds.apache.org/job/POI-with-old-Xerces/117/console

Would I use "ant 1.8.4" or "Ant 1.8.4"? The Wiki-Page seems to indicate
"Ant 1.8.4" is the preferred one, but it is not working, at least not on
this slave...

Dominik.

On Tue, Aug 9, 2016 at 1:12 AM, Gav <gmcdonald@apache.org> wrote:

> Hi,
>
> On Tue, Aug 9, 2016 at 5:28 AM, Dominik Stadler <dominik.stadler@gmx.at>
> wrote:
>
>> Hi,
>>
>> We tried to use Ant 1.8.4 in one of our builds, but it seems to be still
>> missing, at least on this slave. See https://builds.apache.org/view
>> /POI/job/POI-with-old-Xerces/113/console
>>
>
> That was my bad, thanks for reporting, a new version of ant 1.8.4 has been
> rolled out and all slaves should update within the hour.
>
> The slave yours failed on has it already:-
>
> /home/jenkins/tools/ant# ./apache-ant-1.8.4/bin/ant -version
> Apache Ant(TM) version 1.8.4 compiled on May 22 2012
>
> HTH
>
> Gav...
>
> Dominik
>>
>> On Aug 2, 2016 1:58 AM, "Gav" <gmcdonald@apache.org> wrote:
>>
>>> Hi All,
>>>
>>> Following on from my recent JDK and Maven emails, here is the remaining
>>> one we
>>> need to go through, that of Ant. Please find the Matrix of currently
>>> installed versions
>>> at :-
>>>
>>> https://cwiki.apache.org/confluence/display/INFRA/Ant+Installation+Matrix
>>>
>>>
>>>
>>> You will see we have one drop down item labelled 'Ant (latest)' -
>>> currently symlinked to the
>>> very latest 1.9.7 release. We also have versions 1.9.4 and 1.8.4
>>> installed and managed via
>>> puppet.
>>>
>>> I think that is as far back as we need to go. I intend to drop all
>>> auto-installed versions 7 days
>>> from now. So please migrate away from auto-install versions 1.6.5,
>>> 1.7.0, 1.7.1, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.9.3.
>>>
>>> I hope you agree that this consolidation of versions of all these tools
>>> will simplify choices, make them more accurate with what you expect.
>>>
>>> Any follow up questions please direct your email replies to the builds@
>>> mailing list.
>>>
>>> Thanks!
>>>
>>> Gav...
>>>
>>>
>>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message