www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lewis John Mcgibbney <lewis.mcgibb...@gmail.com>
Subject Re: Build failed in Jenkins: joshua_master #4
Date Fri, 01 Apr 2016 16:48:58 GMT
OK Andrew thank you Sir. For the time being we will restrict the
joshua_master [0] to build on ubuntu slaves.

https://builds.apache.org/view/H-L/view/Joshua/job/joshua_master/

i suppose we will see the results Sir.

On Fri, Apr 1, 2016 at 9:20 AM, Andrew Bayer <andrew.bayer@gmail.com> wrote:

> Should be on any of the ubuntu-[1,2,4,5,6] boxes or H10 and H11. Otherwise,
> probably not. As always, if you need system libraries installed, we
> strongly advise you run your build in a docker container, where you can
> control things like that.
>
> A.
>
> On Fri, Apr 1, 2016 at 9:18 AM, Lewis John Mcgibbney <
> lewis.mcgibbney@gmail.com> wrote:
>
> > Hi builds@,
> > The named library is Boost http://www.boost.org/
> > Is this library installed on any build slave?
> >
> > On Fri, Apr 1, 2016 at 7:29 AM, Matt Post <post@cs.jhu.edu> wrote:
> >
> > > Thanks very much! Some of our tests are now passing (17/39), but now I
> > see
> > > that it is unable to locate boost:
> > >
> > >      [exec]   Unable to find the requested Boost libraries.
> > >      [exec]
> > >      [exec]   Boost version: 1.54.0
> > >      [exec]
> > >      [exec]   Boost include path: /usr/include
> > >      [exec]
> > >      [exec]   Could not find the following Boost libraries:
> > >      [exec]
> > >      [exec]           boost_system
> > >      [exec]           boost_thread
> > >      [exec]
> > >      [exec]   Some (but not all) of the required Boost libraries were
> > > found.  You may
> > >      [exec]   need to install these additional Boost libraries.
> > > Alternatively, set
> > >      [exec]   BOOST_LIBRARYDIR to the directory containing Boost
> > libraries
> > > or BOOST_ROOT
> > >      [exec]   to the location of Boost.
> > >
> > > Can you suggest what we can do to address this?
> > >
> > >
> > > > On Apr 1, 2016, at 12:18 AM, Daniel Takamori <pono@apache.org>
> wrote:
> > > >
> > > > The node, ubuntu3, that this job ran on runs 12.04 for compatibility
> > > > reasons and as such has an old version of cmake.  I've gone ahead and
> > > > modified your job from the label "solaris||ubuntu" to
> > > > "solaris||ubuntu&&!(ubuntu3)" to restrict to the newer 14.04 nodes.
> > > >
> > > > Cheers,
> > > > -Pono
> > > >
> > > > On Fri, Apr 1, 2016 at 4:10 AM, Mattmann, Chris A (3980) <
> > > > chris.a.mattmann@jpl.nasa.gov> wrote:
> > > >
> > > >> Send mail to builds@apache.org, I’ve CC’ed them on this message.
> > > >>
> > > >> builds@, please help :)
> > > >>
> > > >> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> > > >> Chris Mattmann, Ph.D.
> > > >> Chief Architect
> > > >> Instrument Software and Science Data Systems Section (398)
> > > >> NASA Jet Propulsion Laboratory Pasadena, CA 91109 USA
> > > >> Office: 168-519, Mailstop: 168-527
> > > >> Email: chris.a.mattmann@nasa.gov
> > > >> WWW:  http://sunset.usc.edu/~mattmann/
> > > >> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> > > >> Director, Information Retrieval and Data Science Group (IRDS)
> > > >> Adjunct Associate Professor, Computer Science Department
> > > >> University of Southern California, Los Angeles, CA 90089 USA
> > > >> WWW: http://irds.usc.edu/
> > > >> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> > > >>
> > > >>
> > > >>
> > > >>
> > > >>
> > > >> -----Original Message-----
> > > >> From: Matt Post <post@cs.jhu.edu>
> > > >> Reply-To: "dev@joshua.incubator.apache.org"
> > > >> <dev@joshua.incubator.apache.org>
> > > >> Date: Thursday, March 31, 2016 at 4:59 PM
> > > >> To: "dev@joshua.incubator.apache.org" <
> > dev@joshua.incubator.apache.org>
> > > >> Cc: "post@jgeppert.com" <post@jgeppert.com>
> > > >> Subject: Re: Build failed in Jenkins: joshua_master #4
> > > >>
> > > >>> (To be clear, I'm asking if anyone knows how we can get a newer
> > version
> > > >>> of cmake installed on build.apache.org...)
> > > >>>
> > > >>>> On Mar 31, 2016, at 7:50 PM, Matt Post <post@cs.jhu.edu>
wrote:
> > > >>>>
> > > >>>> It looks like the first failure is at KenLM. I see:
> > > >>>>
> > > >>>>     CMake Error at CMakeLists.txt:1 (cmake_minimum_required):
> > > >>>>          [exec]   CMake 2.8.8 or higher is required.  You
are
> > running
> > > >>>> version 2.8.7
> > > >>>>
> > > >>>> Is there any way that this can be fixed? CMake on my Mac is
3.4.3.
> > > >>>
> > > >>
> > > >>
> > >
> > >
> >
> >
> > --
> > *Lewis*
> >
>



-- 
*Lewis*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message