www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tomek Rękawek (JIRA) <j...@apache.org>
Subject [jira] [Commented] (BUILDS-68) Please install nokogiri ruby gem on Jenkins slaves
Date Tue, 31 Mar 2015 20:01:53 GMT

    [ https://issues.apache.org/jira/browse/BUILDS-68?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14389284#comment-14389284
] 

Tomek Rękawek commented on BUILDS-68:
-------------------------------------

Hello, I'm interested if this gem could be installed on the Jenkins machine. If not, we can
create a workaround and simply don't use it. Looking forward to the IT response.

> Please install nokogiri ruby gem on Jenkins slaves
> --------------------------------------------------
>
>                 Key: BUILDS-68
>                 URL: https://issues.apache.org/jira/browse/BUILDS-68
>             Project: Infra Build Platform
>          Issue Type: Bug
>          Components: Jenkins
>            Reporter: Robert Munteanu
>
> In the Apache Sling project we have a module which invokes a ruby script which in turn
uses the nokogiri rubygem.
> We would need this installed on Jenkins slaves, otherwise the build fails. The relevant
error is:
> /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file
-- nokogiri (LoadError)
>         from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
>         from ./scripts/bundles.rb:4:in `<main>'



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message