www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Lehmkuehler <andr...@lehmi.de>
Subject Re: Incompatible java version on Ubuntu slaves
Date Sat, 01 Nov 2014 14:47:41 GMT
Hi,

just to avoid missunderstandins, I've switch the mentioned build at least 
temporarily to use java 6 latest

BR
Andreas Lehmkühler

Am 01.11.2014 um 15:33 schrieb Andreas Lehmkuehler:
> Hi,
>
> since today we are getting the following exception when building PDFBox
>
> Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version
> number in .class file
>      at java.lang.ClassLoader.defineClass1(Native Method)
>      at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
>      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
>      at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
>      at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
>      at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
>      at java.security.AccessController.doPrivileged(Native Method)
>      at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
>      at
> org.codehaus.plexus.classworlds.realm.ClassRealm.loadClassFromSelf(ClassRealm.java:386)
>
>      at
> org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:42)
>
>      at
> org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:244)
>      at
> org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:230)
>      at org.jvnet.hudson.maven3.agent.Maven3Main.main(Maven3Main.java:135)
>      at org.jvnet.hudson.maven3.agent.Maven3Main.main(Maven3Main.java:64)
>
>
> The 1.8-branch [1] is the only affected PDFBox build. It uses "JDK 5 (latest)"
> and "Maven 3.0.3". The latter doesn't seems to be compiled with a 1.5 compatible
> JDK but with java 6 or newer. As it works before there has to be a incompatible
> change in the configuration of the ubuntu slaves. It looks as if there wasn't
> any jdk5 installed before and jenkins automatically switched to a jdk7.
>
> The question is what maven version can be used in combination with jdk5 latest?
> Is there any maven 3 version compatible with java 5?
>
> BR
> Andreas Lehmkühler
>
> [1] https://builds.apache.org/job/PDFBox%201.8.x/


Mime
View raw message