www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michi Mutsuzaki (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BUILDS-17) ulimit set too low on some jenkins build hosts
Date Fri, 03 Oct 2014 07:21:33 GMT

    [ https://issues.apache.org/jira/browse/BUILDS-17?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14157758#comment-14157758
] 

Michi Mutsuzaki commented on BUILDS-17:
---------------------------------------

Thank you guys for looking into this.

Now the ulimit command shows that "open files" is set to 60000, but the test is failing with
the same error. I'm a bit puzzled because the same test passes on my local box with the ulimit
set to 40000. Is it possible that somehow jenkins process is not picking up this ulimit? Could
you take a look at /proc/$pid/limits file for the jenkins process?

https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/2368/ (executed on H9)

> ulimit set too low on some jenkins build hosts
> ----------------------------------------------
>
>                 Key: BUILDS-17
>                 URL: https://issues.apache.org/jira/browse/BUILDS-17
>             Project: Infra Build Platform
>          Issue Type: Bug
>          Components: Jenkins
>            Reporter: Patrick Hunt
>            Assignee: Giridharan Kesavan
>            Priority: Blocker
>
> Our precommit job is failing, this started just after the recent major upgrades to the
jenkins infra (was fine prior to that):
> https://builds.apache.org/view/S-Z/view/ZooKeeper/job/PreCommit-ZOOKEEPER-Build/2303/
> The test is still failing with the same error (too many open
> files) and afaict the ulimit is still just set to 4k. I'm printing the
> ulimit info at the start of the job, here it is:
> core file size          (blocks, -c) 0
> data seg size           (kbytes, -d) unlimited
> scheduling priority             (-e) 0
> file size               (blocks, -f) unlimited
> pending signals                 (-i) 386177
> max locked memory       (kbytes, -l) 64
> max memory size         (kbytes, -m) unlimited
> open files                      (-n) 4096
> pipe size            (512 bytes, -p) 8
> POSIX message queues     (bytes, -q) 819200
> real-time priority              (-r) 0
> stack size              (kbytes, -s) 8192
> cpu time               (seconds, -t) unlimited
> max user processes              (-u) 386177
> Please increase the ulimit to a significantly larger value (perhaps you can set it to
what it was set to prior to the upgrade?)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message