www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler" <uschind...@apache.org>
Subject Deploying Maven artifacts from Jenkins to Nexus fails every time
Date Mon, 25 Aug 2014 10:05:36 GMT
Hi,

since a few days we get the following error when deploying snapshot artifacts to Jenkins:

Build Log:
[...truncated 25266 lines...]
BUILD FAILED
/usr/home/jenkins/jenkins-slave/workspace/Lucene-Solr-Maven-4.x/build.xml:501: The following
error occurred while executing this line:
/usr/home/jenkins/jenkins-slave/workspace/Lucene-Solr-Maven-4.x/build.xml:174: The following
error occurred while executing this line:
/usr/home/jenkins/jenkins-slave/workspace/Lucene-Solr-Maven-4.x/lucene/build.xml:492: The
following error occurred while executing this line:
/usr/home/jenkins/jenkins-slave/workspace/Lucene-Solr-Maven-4.x/lucene/common-build.xml:581:
Error deploying artifact 'org.apache.lucene:lucene-solr-grandparent:pom': Error retrieving
previous build number for artifact 'org.apache.lucene:lucene-solr-grandparent:pom': repository
metadata for: 'snapshot org.apache.lucene:lucene-solr-grandparent:4.11.0-SNAPSHOT' could not
be retrieved from repository: apache.snapshots.https due to an error: Error transferring file:
Server returned HTTP response code: 502 for URL: https://repository.apache.org/content/repositories/snapshots/org/apache/lucene/lucene-solr-grandparent/4.11.0-SNAPSHOT/maven-metadata.xml

Total time: 14 minutes 7 seconds
Build step 'Invoke Ant' marked build as failure Recording test results Email was triggered
for: Failure Sending email for trigger: Failure


Looking for the cause of the problem, we only know that the username was changed from "hudson"
-> "jenkins" recently for the build slaves (also for the Lucene build machine, I took care
of that). But the login user name of Nexus is still "ci-hudson" as specified in settings.xml.
Is there anything to change? I know, error 502 is not "access denied", but it could be related.

The build machine failing is: lucene.zones.apache.org

Does anybody know whats going on?

Uwe

-----
Uwe Schindler
uschindler@apache.org 
Apache Lucene PMC Member / Committer
Bremen, Germany
http://lucene.apache.org/



Mime
View raw message