www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From OmPrakash Muppirala <bigosma...@gmail.com>
Subject Re: [windows1] Pixelbender installation
Date Tue, 10 Dec 2013 22:35:49 GMT
Thanks Gav!

We did a bunch of tests to repro this issue on our side.  One way we could
reproduce this on our Jenkins installation was that if we ran the job as a
service, we are getting the same error messages (AIF Internal exception).

Jenkins docs says that for jobs that require Desktop Access (which Pixel
Bender does), the root service process that is running the job needs to
have the 'interactive flag' enabled in the Windows Service Manager. [1]

One way this setting could have changed is if the way the windows slave
starts was modified.

Can you please take a look under the hood and see if you find something
amiss?

Thanks,
Om

[1]
https://wiki.jenkins-ci.org/display/JENKINS/My+software+builds+on+my+computer+but+not+on+Jenkins


On Tue, Dec 10, 2013 at 2:11 PM, Gavin McDonald <gavin@16degrees.com.au>wrote:

>
>
> > -----Original Message-----
> > From: Erik de Bruin [mailto:erik@ixsoftware.nl]
> > Sent: Tuesday, 10 December 2013 7:14 PM
> > To: builds@apache.org
> > Cc: Gavin McDonald
> > Subject: Re: [windows1] Pixelbender installation
> >
> > Gavin,
> >
> > Can you please copy-paste this line into a command prompt and tell us
> what
> > the result is:
> >
> > "%PIXELBENDER_HOME%\pbutil.exe"
> > "F:\hudson\hudson-slave\workspace\flex-
> > sdk\frameworks\projects\framework\src\mx\graphics\shaderClasses\Color.
> > pbk"
> > "F:\hudson\hudson-slave\workspace\flex-
> > sdk\frameworks\projects\framework\src\mx\graphics\shaderClasses\Color.
> > pbj"
> >
> > (mind the wrap)
> >
> > Thanks!
>
> Result is a slight pause, then the prompt returns. No error, no output.
>
> (PixelBender is where its meant to be, PIXELBENDER_HOME is a user
> variable.)
>
> Let me know what's next to check , thanks
>
> Gav...
>
> >
> > EdB
> >
> >
> >
> > On Mon, Dec 9, 2013 at 11:16 PM, OmPrakash Muppirala
> > <bigosmallm@gmail.com> wrote:
> > > On Mon, Dec 9, 2013 at 2:02 PM, Gavin McDonald
> > <gavin@16degrees.com.au>wrote:
> > >
> > >> That's fine, I'll take a look. All I'm trying to get across is that
> > >> NOTHING HAS CHANGED on the Windows slave, so is it very slightly
> > >> possible that the build is failing due to a coding error? In other
> > >> words, I've been blamed several times now for breaking the build when
> > >> I haven't been anywhere near the machine in question.
> > >>
> > >>
> > > The build does not fail on my or other committers' machines.  It must
> > > be something specific to whats happening in Windows1.  Sorry if it
> > > sounds like we are blaming you.  We are just trying to troubleshoot
> > > and are running blind here.
> > >
> > >
> > >
> > >>
> > >>
> > >> Either way I'll look.
> > >>
> > >
> > > Thanks!
> > >
> > >
> > >>
> > >>
> > >> And so that we are clear, windows1 is not going away, it is very
> > >> heavily used, folks are always complaining it is down, so I'm adding
> > >> a 2ndwindows2 slave in addition to the windows1 slave. Point is, you
> > >> need to be configured to use both slaves for it to work, or my time
> > building a 2ndmachine is wasted and you'll continue to complain about the
> 1
> > st windows box being overloaded all the time.
> > >>
> > >>
> > >>
> > >
> > > We welcome the addition of a new windows slave, no doubt.  Which is
> > > why we want to fix Windows1 first.  Otherwise it will lead to more
> > > variables to troubleshoot.
> > >
> > > On that note, perhaps you can image windows1 and create windows2 as a
> > > clone of it?
> > >
> > > Regards,
> > > Om
> > >
> > >
> > >> Gav.
> > >>
> > >>
> > >>
> > >>
> > >>
> > >> *From:* omuppi1@gmail.com [mailto:omuppi1@gmail.com] *On Behalf
> > Of
> > >> *OmPrakash Muppirala
> > >> *Sent:* Tuesday, 10 December 2013 7:28 AM
> > >> *To:* builds@apache.org
> > >> *Cc:* Gavin McDonald
> > >>
> > >> *Subject:* Re: [windows1] Pixelbender installation
> > >>
> > >>
> > >>
> > >> Gavin,
> > >>
> > >> This issue is unrelated to Windows2 slave.  Our long running job on
> > >> Windows1 has started failing for the past few days.  Can we first fix
> > >> that before we start working on Windows2?
> > >>
> > >> Or, is Windows2 a replacement for Windows1?
> > >>
> > >>
> > >>
> > >> Thanks,
> > >> Om
> > >>
> > >>
> > >>
> > >> On Sat, Dec 7, 2013 at 12:35 AM, Erik de Bruin <erik@ixsoftware.nl>
> > wrote:
> > >>
> > >> Ok, from the top of this thread:
> > >>
> > >> "The build on windows1 is failing on the 'Pixelbender' task:
> > >>
> > >>
> > >> The build assumes Pixelbender is installed at:
> > >>
> > >> PIXELBENDER_HOME=C\:/Program\ Files\ (x86)/Adobe/Adobe Utilities\ -
> > \
> > >> CS5/Pixel\ Bender\ Toolkit\ 2
> > >>
> > >> Is that still the correct path and does the application start without
> > >> errors when you launch it manually?"
> > >>
> > >> In another email in this thread I've listed the software that needs
> > >> to be on windows2.
> > >>
> > >> Is there a way to have all our builds run on either windows1 OR
> > >> windows2? Most of our jobs depend on files in the workspaces of some
> > >> of our other builds, in order to save on disk space and build time.
> > >> If we remove these dependencies, we'd basically be forced to copy
> > >> each build into each other build.
> > >>
> > >> Since it is the weekend, I'll have limited time to work with you,
> > >> sorry. Next Monday I'll be glad to check/test/adjust whatever needs
> > >> checking/testing/adjusting.
> > >>
> > >> Please keep in mind that we are at a very important milestone for our
> > >> project, and with third party teams relying on our nightly builds,
> > >> we'd greatly appreciate a successful run of all our jobs, on whatever
> > >> slave works.
> > >>
> > >>
> > >> EdB
> > >>
> > >>
> > >>
> > >> --
> > >> Ix Multimedia Software
> > >>
> > >> Jan Luykenstraat 27
> > >> 3521 VB Utrecht
> > >>
> > >> T. 06-51952295
> > >> I. www.ixsoftware.nl
> > >>
> > >>
> > >>
> >
> >
> >
> > --
> > Ix Multimedia Software
> >
> > Jan Luykenstraat 27
> > 3521 VB Utrecht
> >
> > T. 06-51952295
> > I. www.ixsoftware.nl
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message