www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gavin McDonald" <ga...@16degrees.com.au>
Subject RE: Windows1 is offline
Date Tue, 19 Nov 2013 10:50:30 GMT


> -----Original Message-----
> From: Gavin McDonald [mailto:gavin@16degrees.com.au]
> Sent: Monday, 18 November 2013 9:09 AM
> To: builds@apache.org
> Subject: RE: Windows1 is offline
> 
> 
> 
> > -----Original Message-----
> > From: Erik de Bruin [mailto:erik@ixsoftware.nl]
> > Sent: Monday, 18 November 2013 3:22 AM
> > To: builds@apache.org; jfarrell@apache.org
> > Subject: Re: Windows1 is offline
> >
> > With at least a couple of windows builds in the queue, windows1 is
> > showing offline again...
> 
> Will take another look, but see below, it won't be today unless another
> volunteer decides to step in.
> 
> >
> > Due to the slave being offline and other builds getting stuck, we
> > haven't been able to build the majority of our jobs for nearly 5 days
now.
> 
> In the industry, when one does CI builds in their own organisation, the CI
> systems can and usually are tailored for their builds only, their software
only,
> their product only. It makes for an easier setup. At the ASF, we have to
> contend with other projects building completely different software on the
> same systems, sometimes, this can make slaves behave in ways we can not
> predict. We do need to look at the current slave to see what can be
tweaked
> to make it more stable for all the software being built/used on it. That
will
> require much more than a reboot and see how it goes so please be patient
> and rest assured it is being looked into.
> 
> > So much for the "continuous" in CI :-(
> 
> That did not help the request in any way and is not encouraging to
volunteers
> who might have wanted to help.
> 
> >
> > Can someone please take a closer look at what's up with this slave?
> 
> My priorities here can and do change all the time, based on a number of
> criteria. What I'm going to do next is build a 2nd Windows slave from
scratch
> on a new VM. It'll be Windows Server 2012 R2 with more memory and more
> disk space. Folks can then move their builds to this slave when ready
leaving
> the other one (based on Server 2008) to be cleaned up and/or rebuilt.

Replying to myself here, for some reason I could not get a Win 2012 server
to install on our
vmware version, so it'll be another Win 2008 Server. I've installed that on
a new VM and all I
need to do now is install Jenkins/Java/Etc then hook it up. Should be ready
in a few hours.

Gav...

> 
> HTH
> 
> Gav...
> 
> >
> > Thanks,
> >
> > EdB
> >
> >
> >
> > On Thu, Nov 7, 2013 at 9:32 PM, Erik de Bruin <erik@ixsoftware.nl>
wrote:
> > > Thanks!
> > >
> > > EdB
> > >
> > >
> > >
> > > On Thursday, November 7, 2013, Jake Farrell wrote:
> > >>
> > >> backup, hung jobs purged and building as expected now
> > >>
> > >> -Jake
> > >>
> > >>
> > >> On Thu, Nov 7, 2013 at 2:35 PM, Erik de Bruin <erik@ixsoftware.nl>
> wrote:
> > >>
> > >> > Bump...
> > >> >
> > >> > EdB
> > >> >
> > >> >
> > >> >
> > >> > On Wed, Nov 6, 2013 at 6:42 PM, Erik de Bruin
> > >> > <erik@ixsoftware.nl>
> > >> > wrote:
> > >> > > It shows offline again... and there are plenty eligible builds
> > >> > > in the queue, so it's not 'resting' before something comes along.
> > >> > >
> > >> > > EdB
> > >> > >
> > >> > >
> > >> > >
> > >> > > On Wed, Nov 6, 2013 at 6:26 PM, Richard Eckart de Castilho
> > >> > > <richard.eckart@gmail.com> wrote:
> > >> > >> There is currently a build enqueued for windows1, but it
> > >> > >> doesn't come
> > >> > >> online:
> > >> > >>
> > >> > >>   https://builds.apache.org/job/UIMA-uimaFIT/
> > >> > >>   build #163
> > >> > >>
> > >> > >> Node status: Ping response time is too long or timed out.
> > >> > >>
> > >> > >> -- Richard
> > >> > >>
> > >> > >> On 08.09.2013, at 10:53, Gavin McDonald
> > <gavin@16degrees.com.au>
> > >> > >> wrote:
> > >> > >>
> > >> > >>>
> > >> > >>>
> > >> > >>>> -----Original Message-----
> > >> > >>>> From: Erik de Bruin [mailto:erik@ixsoftware.nl]
> > >> > >>>> Sent: Sunday, 8 September 2013 5:17 PM
> > >> > >>>> To: builds@apache.org; Gavin McDonald
> > >> > >>>> Subject: Re: Windows1 is offline
> > >> > >>>>
> > >> > >>>> I do not email "every time." I don't even email when
it
> > >> > >>>> going offline
> > >> > >>> disrupts
> > >> > >>>> one of our jobs, causing it to fail without notifying
us. I
> > >> > >>>> wait for
> > >> > 24
> > >> > >>> hours after
> > >> > >>>> that and if it is STILL offline, I email. Am I doing
it wrong?
> > >> > >>>
> > >> > >>> Nope, that's fine, I'm making sure you know that 'offline'
is
> > >> > >>> ok is no builds are in waiting.
> > >> > >>>
> > >> > >>> Please feel free to continue to bug us if you feel there
is
> > >> > >>> an issue.
> > >> > >>>
> > >> > >>> Thanks
> > >> > >>>
> > >> > >>> Gav...
> > >> > >>>
> > >> > >>>>
> > >> > >>>> EdB
> > >> > >>>>
> > >> > >>>>
> > >> > >>>> On Sun, Sep 8, 2013 at 2:55 AM, Gavin McDonald
> > >> > >>>> <gavin@16degrees.com.au> wrote:
> > >> > >>>>>
> > >> > >>>>>
> > >> > >>>>>> -----Original Message-----
> > >> > >>>>>> From: Erik de Bruin [mailto:erik@ixsoftware.nl]
> > >> > >>>>>> Sent: Saturday, 7 September 2013 10:46 PM
> > >> > >>>>>> To: builds@apache.org
> > >> > >>>>>> Subject: Re: Windows1 is offline
> > >> > >>>>>>
> > >> > >>>>>> And... it's offline again!
> > >> > >>>>>>
> > >> > >>>>>> Please, pretty please, can we have a more
permanent
> > >> > >>>>>> solution to whatever is causing this node
to go offline
> > >> > >>>>>> time after
> time?
> > >> > >>>>>
> > >> > >>>>> Please do not email every time it goes offline
unless there
> > >> > >>>>> are
> > >> > builds
> > >> > >>>>> waiting for it.
> > >> > >>>>> The windows slave, and others, are configured
to go offline
> > >> > >>>>> on
> > >> > purpose
> > >> > >>>>> until a build requests it to come back up.
> > >> > >>>>>
> > >> > >>>>> I've checked, its up and building.
> > >> > >>>>>
> > >> > >>>>> Gav...
> > >> > >>
> > >> > >
> > >> > >
> > >> > >
> > >> > > --
> > >> > > Ix Multimedia Software
> > >> > >
> > >> > > Jan Luykenstraat 27
> > >> > > 3521 VB Utrecht
> > >> > >
> > >> > > T. 06-51952295
> > >> > > I. www.ixsoftware.nl
> > >> >
> > >> >
> > >> >
> > >> > --
> > >
> > >
> > >
> > > --
> > > Ix Multimedia Software
> > >
> > > Jan Luykenstraat 27
> > > 3521 VB Utrecht
> > >
> > > T. 06-51952295
> > > I. www.ixsoftware.nl
> >
> >
> >
> > --
> > Ix Multimedia Software
> >
> > Jan Luykenstraat 27
> > 3521 VB Utrecht
> >
> > T. 06-51952295
> > I. www.ixsoftware.nl



Mime
View raw message