www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Lamy <ol...@apache.org>
Subject Re: analysis jenkins has old JDK
Date Mon, 16 Sep 2013 02:41:08 GMT
fixed.
What are the other projects?

On 15 September 2013 00:40, Mark Struberg <struberg@yahoo.de> wrote:
>
>
> Hi!
>
> Quite a few projects fail to build on our Sonar server due to an old JDK.
>
> https://analysis.apache.org/jenkins/job/openwebbeans/
> for example uses jdk-1.6.022 which is from at least 2010.
>
> Can someone please update those projects to the latest available java6 JDK?
>
>
> A typical error which results from this old JDK version are the one like the following:
>
>
> INFO: --- maven-compiler-plugin:2.3.2:testCompile (default-testCompile) @ openwebbeans-impl
---
> [INFO] Compiling 782 source files to /x1/jenkins/jenkins-master/jenkins-home/jobs/openwebbeans/workspace/webbeans-impl/target/test-classes
> [INFO] ------------------------------------------------------------- [ERROR] COMPILATION
ERROR : [INFO] ------------------------------------------------------------- [ERROR] /x1/jenkins/jenkins-master/jenkins-home/jobs/openwebbeans/workspace/webbeans-impl/src/test/java/org/
> apache/webbeans/test/mock/MockManager.java:[144,33] type parameters of <T>T cannot
be
> determined; no unique maximal instance exists for type variable T with upper bounds T,java.lang.Object
>
>
> txs and LieGrue,
> strub
>



-- 
Olivier Lamy
Ecetera: http://ecetera.com.au
http://twitter.com/olamy | http://linkedin.com/in/olamy

Mime
View raw message