www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marvin Humphrey <mar...@rectangular.com>
Subject RAT report and Git repository dir
Date Wed, 24 Jul 2013 16:40:34 GMT
Greets,

I'm having difficulty excluding the contents of the `.git` repository
directory from Lucy's buildbot-generated RAT report.

    http://ci.apache.org/projects/lucy/rat-output.html

Here are the relevant configs and our rat-excludes file:

    https://svn.apache.org/repos/infra/infrastructure/buildbot/aegis/buildmaster/master1/projects/lucy.conf
    https://svn.apache.org/repos/infra/infrastructure/buildbot/portunus/buildslave2/slave2/rat-buildfiles/lucy.xml
    https://git-wip-us.apache.org/repos/asf?p=lucy.git;a=blob;f=devel/conf/rat-excludes;h=3927a34fd3fb69e0785b6ceb14f0e58ca8b99d9b;hb=HEAD

I tried running the ant task locally with a checkout of RAT trunk, and found
that the .git directory was excluded by default.  (RAT 0.8 is specified in
lucy.xml, but would not build for me.)  Unfortunately, I have been unable to
duplicate the problem locally.

I am confused as to why Libcloud's RAT report does not exhibit the same
problem.

    http://ci.apache.org/projects/libcloud/rat-output.html

Libcloud also uses Git for source control and their RAT excludes file does not
contain any specific rules for the `.git` dir.  I don't see anything that
would explain the difference in their config files.

    https://svn.apache.org/repos/infra/infrastructure/buildbot/aegis/buildmaster/master1/projects/libcloud.conf
    https://svn.apache.org/repos/infra/infrastructure/buildbot/bb-vm1/buildslave3/slave3/rat-buildfiles/libcloud.xml
    https://git-wip-us.apache.org/repos/asf?p=libcloud.git;a=blob;f=.ratignore;h=ba54ecd9cd78d89afb0e1b464dceb2e485e75a59;hb=HEAD

Any ideas?

Marvin Humphrey

Mime
View raw message