www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Munteanu <romb...@apache.org>
Subject Re: sling-trunk-1.6 build fails due to a java.io.UTFDataFormatException
Date Wed, 05 Jun 2013 10:00:48 GMT
Hi Jake,

The build still fails, even with these changes.

https://builds.apache.org/job/sling-trunk-1.6/org.apache.sling$org.apache.sling.jcr.resource/1684/consoleText

Can you please revert the 'Disable automatic artifact archiving' change and
see if there's another root cause?

Thanks,

Robert


On Sat, May 18, 2013 at 9:33 PM, Robert Munteanu <robert@lmn.ro> wrote:

>
> That was done intentionally since we don't need them and increases the
> build time + space usage. Build 1662 [1] ( no archiving ) took 38 minutes,
> while build 1663 [2] ( with archiving ) took 59 minutes. And I still see
> 'Maven failed with error' in the 1663 logs.
>
> Why did your config change fix our problem?
>
> [1]: https://builds.apache.org/job/sling-trunk-1.6/1662/
> [2]: https://builds.apache.org/job/sling-trunk-1.6/1663/
>
>
> On Sat, May 18, 2013 at 8:04 PM, Jake Farrell <jfarrell@apache.org> wrote:
>
>> Builds > Disable automatic artifact archiving was selected
>>
>> -Jake
>>
>>   Robert Munteanu <robert@lmn.ro>
>>  May 18, 2013 12:07 PM
>> Thanks for fixing this!
>>
>> BTW, what was the exact issue? I'd like to know so that it is recorded in
>> our change history. And yes, we have some failing tests, but I wanted to
>> take them one step at a time.
>>
>> Robert
>>
>>
>>
>>
>>   Jake Farrell <jfarrell@apache.org>
>>  May 18, 2013 12:05 PM
>>  Robert
>> There was an issue with your build configuration, I have fixed your
>> settings and your build is running again
>>
>> https://builds.apache.org/job/sling-trunk-1.6/1663
>>
>> There is an problem with one of your test cases which you will have to
>> look into (Apache Sling Launchpad Testing WAR version)
>>
>> Failed tests:
>> testRunScripts(org.apache.sling.launchpad.webapp.integrationtest.ServerSideScriptsTest):
>> POST request to http://localhost:46012/apps: expecting status 302
>> expected:<302> but was:<503>
>>
>> If you have any questions let me know
>> -Jake
>>
>>
>>
>>
>>
>>
>>   Robert Munteanu <rombert@apache.org>
>>  May 18, 2013 11:13 AM
>>
>> On Sat, May 18, 2013 at 5:49 PM, Jake Farrell <jfarrell@apache.org> <jfarrell@apache.org>
wrote:
>>
>> Hi Robert
>> Looking into your issue
>>
>> -Jake
>>
>> Hi Jake,
>>
>> Thanks for doing that. Let me know if I can help with any information or action.
>>
>> Cheers,
>>
>> Robert
>>
>>
>> Robert Munteanu
>> May 18, 2013 9:13 AM
>> Hi,
>>
>> The sling-trunk-1.6 build fails with the mentioned error at the end of
>> the build . This is a maven build running on an ubuntu slave. Does
>> anyone have an idea where it is coming from?
>>
>> There are more details about a failing build at [1].
>>
>> Thanks,
>>
>> Robert
>>
>> [1]: https://builds.apache.org/job/sling-trunk-1.6/1662/consoleText
>>
>>   Jake Farrell <jfarrell@apache.org>
>>  May 18, 2013 10:49 AM
>>  Hi Robert
>> Looking into your issue
>>
>> -Jake
>>
>>
>>   Robert Munteanu <rombert@apache.org>
>>  May 18, 2013 9:13 AM
>> Hi,
>>
>> The sling-trunk-1.6 build fails with the mentioned error at the end of
>> the build . This is a maven build running on an ubuntu slave. Does
>> anyone have an idea where it is coming from?
>>
>> There are more details about a failing build at [1].
>>
>> Thanks,
>>
>> Robert
>>
>> [1]: https://builds.apache.org/job/sling-trunk-1.6/1662/consoleText
>>
>>
>
>
> --
> Sent from my (old) computer
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message