www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Veithen <andreas.veit...@gmail.com>
Subject Re: Jenkins broken: cannot find Maven
Date Sat, 05 Jan 2013 12:12:13 GMT
Yes, builds are stable now. Thanks for looking into this.

Andreas

On Thu, Jan 3, 2013 at 11:16 PM, Gavin McDonald <gavin@16degrees.com.au> wrote:
>
>
>> -----Original Message-----
>> From: Andreas Veithen [mailto:andreas.veithen@gmail.com]
>> Sent: Monday, 31 December 2012 9:41 PM
>> To: builds@apache.org
>> Subject: Re: Jenkins broken: cannot find Maven
>>
>> Are you describing the change that you believe broke the builds or a
> change
>> that you did to try to fix the issue?
>
> Describing what broke it. The builds have now caught up with the change so
> all good again.
>
> Gav...
>
>>
>> Currently the build in question is configured with Maven 3.0.4 (not Maven
>> latest) and it fails with this message:
>>
>> Started by an SCM change
>> Building remotely on ubuntu3 in workspace /home/jenkins/jenkins-
>> slave/workspace/ws-axiom-trunk
>> Updating
>> http://svn.apache.org/repos/asf/webservices/commons/trunk/modules/axi
>> om
>> U         modules/axiom-
>> api/src/main/java/org/apache/axiom/locator/PriorityBasedOMMetaFactoryL
>> ocator.java
>> U         modules/axiom-
>> api/src/main/java/org/apache/axiom/locator/DefaultOMMetaFactoryLocato
>> r.java
>> U         pom.xml
>> At revision 1427081
>> ERROR: Maven Home /home/hudson/tools/maven/apache-maven-3.0.4
>> doesn't exist
>>
>> Andreas
>>
>> On Mon, Dec 31, 2012 at 12:02 PM, Gavin McDonald
>> <gavin@16degrees.com.au> wrote:
>> >
>> >
>> >> -----Original Message-----
>> >> From: Andreas Veithen [mailto:andreas.veithen@gmail.com]
>> >> Sent: Monday, 31 December 2012 8:31 PM
>> >> To: builds@apache.org
>> >> Subject: Jenkins broken: cannot find Maven
>> >>
>> >> Today, several builds started to fail with an error similar to this
> one:
>> >>
>> >> Building remotely on ubuntu2 in workspace /home/hudson/hudson-
>> >> slave/workspace/ws-axiom-trunk
>> >> ERROR: A Maven installation needs to be available for this project to
>> >> be built.Either your server has no Maven installations defined, or
>> >> the
>> > requested
>> >> Maven version does not exist.
>> >> Retrying after 10 seconds
>> >> ERROR: A Maven installation needs to be available for this project to
>> >> be built.Either your server has no Maven installations defined, or
>> >> the
>> > requested
>> >> Maven version does not exist.
>> >> Retrying after 10 seconds
>> >> ERROR: A Maven installation needs to be available for this project to
>> >> be built.Either your server has no Maven installations defined, or
>> >> the
>> > requested
>> >> Maven version does not exist.
>> >>
>> >> Did somebody do something with the Maven installations?
>> >
>> > The 'latest' and 'latest3' symlinks were changed from 3.0.3 to 3.0.4
>> >
>> > gmcdonald@janus:~$ /home/jenkins/tools/maven/latest3/bin/mvn --
>> version
>> > Apache Maven 3.0.4 (r1232337; 2012-01-17 08:44:56+0000) Maven home:
>> > /home/jenkins/tools/maven/latest3
>> >
>> > Gav...
>> >
>> >>
>> >> Andreas
>> >
>

Mime
View raw message