www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Veithen <andreas.veit...@gmail.com>
Subject Re: HBase TRUNK build 2616 hangs
Date Sat, 07 Jan 2012 13:33:05 GMT
BTW, here is a screenshot that shows the problem:

http://people.apache.org/~veithen/axis2-builds.png

The three Axis2 builds all use the same lock.

Andreas

On Sat, Jan 7, 2012 at 13:38, Andreas Veithen <andreas.veithen@gmail.com> wrote:
> We've seen similar issues with Axis2 builds in the past. I had the
> impression that this has something to do with the usage of locks. We
> are using a lock for the Axis2 builds (because they use fixed port
> numbers in unit tests and therefore can't be executed concurrently).
> Interestingly the hbase build also uses a lock.
>
> Speculating further on the possible cause, what we have seen with
> Axis2 was that sometimes two (or more) different builds (for different
> branches) where triggered at the same time by the completion of a
> common upstream build (Axiom trunk e.g.). Since the Axis2 builds use a
> common lock, one would expect that only one starts execution, while
> the others remain in the build queue. However, what happened is that
> sometimes, two builds started execution in parallel, with one waiting
> for the lock (i.e. instead of waiting in the build queue, it was
> assigned to an executor and waiting there). I had the impression that
> this kind of situation increases the probability of ending up in a
> situation where the build is stuck or reported as being assigned to
> master.
>
> I haven't seen this in a while for the Axis2 builds, but this may be
> simply because the dependencies between builds have changed in the
> meantime.
>
> Andreas
>
> On Sat, Jan 7, 2012 at 13:16, sebb <sebbaz@gmail.com> wrote:
>> On 7 January 2012 03:20, Ted Yu <yuzhihong@gmail.com> wrote:
>>> Hi,
>>> I tried to terminate build 2616 but couldn't:
>>> https://builds.apache.org/view/G-L/view/HBase/job/HBase-TRUNK/2616/
>>
>> Looks like a Jenkins bug - the summary says
>>
>> "Started 10 hr ago
>> Build is being executed for null on master"
>>
>> and the tooltip text in build history says:
>>
>> "Started null ago
>> Estimated remaining time: null"
>>
>>> Please stop this build.
>>>
>>> Thanks

Mime
View raw message