www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject [Jenkins] Unable to locate the default Javac Compiler (ubuntu2)
Date Tue, 29 Nov 2011 19:08:43 GMT
The HttpComponents build keeps getting an error such as  [1]:

[ERROR] Unable to locate the Javac Compiler in:
  /usr/lib/jvm/java-6-openjdk/jre/../lib/tools.jar
Please ensure you are using JDK 1.4 or above and
not a JRE (the com.sun.tools.javac.Main class is required).
In most cases you can change the location of your Java
installation by setting the JAVA_HOME environment variable.

The same build works fine on ubuntu3 and ubuntu5

Is ubuntu2 supposed to be different, or is that an oversight?

At present, the build job uses the (Default) compiler.

I can change that to use a specific version, but I would expect the
(default) to work on all systems that have a Java compiler.

[1] https://builds.apache.org/job/HttpComponents%20AsyncClient/154/console

Mime
View raw message