www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stack <st...@duboce.net>
Subject Re: HBase-0.92 build 162 hangs
Date Wed, 30 Nov 2011 21:25:24 GMT
On Thu, Nov 24, 2011 at 12:08 PM, Niklas Gustavsson
<niklas@protocol7.com> wrote:
> On Thu, Nov 24, 2011 at 4:57 PM, Stack <stack@duboce.net> wrote:
>> There is zero output showing on console.  It looks like my build has
>> not even started.  I have nothing to go on.  This hang is not
>> reproducible off Jenkins.  Do you have suggestion on how I might debug
>> this in Jenkins context?
>
> A couple of ideas would be to check with Jenkins devs on what could
> cause a build to not even get started. Also, perhaps checking in a
> local Jenkins installation. If you do, make sure you run the build on
> a slave over SSH as that seems to affect behavior quite a lot.
>

You mean the user maliing list on jenkins-ci.org or elsewhere?  (I
looked on this page,
http://wiki.apache.org/general/Jenkins?action=show&redirect=Hudson,
but saw nothing particular to my case).

I'd ask "What could cause a build to not even start and yet hang
indefinetly?"  They'd probably want some detail beyond that.

I see we are at 1.431.  Do you have anything else I might volunteer
other than its the apache jenkins?  For example, were you able to
garner any clues from the hung process?   A java thread dump or
perhaps ssh was stuck trying to do setup?  Do you think this hang was
an instance of https://issues.jenkins-ci.org/browse/JENKINS-9688?
(Regards slave over ssh, thats how all builds work up on apache
jenkins?)

For sure no one else has hung jenkins in same way?  It strikes me as
odd that before checkout of our project, before we even get a start,
that we are doing something that is particular to us that brings on
this hang.

Thanks and sorry again for any pain caused,
St.Ack

Mime
View raw message