www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: often finding failures to deploy after successful build
Date Wed, 05 Oct 2011 20:51:16 GMT
thanks, they're working now.

-Marshall

On 10/5/2011 12:23 PM, Olivier Lamy wrote:
> Hello,
> I have just added the repository id (apache.snapshots.https) in maven
> deployer configuration and it works better at least add ons.
> sdk build is waiting an executor.
>
> 2011/10/5 Marshall Schor <msa@schor.com>:
>> Does 401 mean some kind of permissions failure?  Is there something we need to
>> do have Jenkins have permission to deploy to the Snapshot repo at
>> repository.apache.org?
>>
>> -Marshall
>>
>> On 10/4/2011 3:06 PM, Marshall Schor wrote:
>>> Frequently, our builds report "failure", but when we look we find the build
>>> itself was "Successful", but at the end of the build, some Jenkins action to
>>> deploy to the snapshot repository fails with code "401".
>>>
>>> Here's an example:
>>>
>>> [INFO] BUILD SUCCESS
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] Total time: 15:09.417s
>>> [INFO] Finished at: Tue Oct 04 18:17:10 UTC 2011
>>> [INFO] Final Memory: 48M/196M
>>> [INFO] ------------------------------------------------------------------------
>>> channel stopped
>>> Maven RedeployPublished use remote ubuntu1 maven settings from : /home/jenkins/.m2/settings.xml
>>> [ERROR] uniqueVersion == false is not anymore supported in maven 3
>>> [INFO] Deployment in https://repository.apache.org/content/repositories/snapshots
(id=,uniqueVersion=false)
>>> Deploying the main artifact AlchemyAPIAnnotator-2.3.2-SNAPSHOT.jar
>>> Downloading: https://repository.apache.org/content/repositories/snapshots/org/apache/uima/AlchemyAPIAnnotator/2.3.2-SNAPSHOT/maven-metadata.xml
>>> Downloaded: https://repository.apache.org/content/repositories/snapshots/org/apache/uima/AlchemyAPIAnnotator/2.3.2-SNAPSHOT/maven-metadata.xml
(2 KB at 2.0 KB/sec)
>>> Uploading: https://repository.apache.org/content/repositories/snapshots/org/apache/uima/AlchemyAPIAnnotator/2.3.2-SNAPSHOT/AlchemyAPIAnnotator-2.3.2-20111004.181713-3.jar
>>> Uploading: https://repository.apache.org/content/repositories/snapshots/org/apache/uima/AlchemyAPIAnnotator/2.3.2-SNAPSHOT/AlchemyAPIAnnotator-2.3.2-20111004.181713-3.pom
>>> ERROR: Failed to deploy artifacts: Could not transfer artifact org.apache.uima:AlchemyAPIAnnotator:jar:2.3.2-20111004.181713-3
from/to  (https://repository.apache.org/content/repositories/snapshots): Failed to transfer
file: https://repository.apache.org/content/repositories/snapshots/org/apache/uima/AlchemyAPIAnnotator/2.3.2-SNAPSHOT/AlchemyAPIAnnotator-2.3.2-20111004.181713-3.jar.
Return code is: 401
>>>
>>>
>>> Full output is here: https://builds.apache.org/job/UIMA%20Addons/94/console
>>>
>>> Anyone have any ideas how to fix this?
>>>
>>> -Marshall
>>>
>>>
>>>
>
>

Mime
View raw message