www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: Continuum - Commons Pool unit test is stuck (again)
Date Tue, 13 Sep 2011 08:41:55 GMT
On 13 September 2011 00:21, Brett Porter <brett@apache.org> wrote:
>
> On 13/09/2011, at 3:27 AM, sebb wrote:
>
>>
>>>>
>>>> BTW, is there a way to limit the time Continuum allows tests to run?
>>>
>>> Doneā€¦ but it will probably leave any dead builds behind.
>>
>> Is that a system-wide setting?
>
> It's a setting for the builds on that schedule. Since commons was on a separate schedule
it hadn't been set, but the main one was.

What's the setting now please?

Continuum does not seem to allow even read-only access to such settings.

>>
>>> Do you have any idea what's causing them to hang?
>>
>> No idea why they are hanging yet, but I have raised the issue in Commons.
>> We can hopefully add a test timeout, which should avoid the zombies.
>
> Cool, thanks!

In case it helps anyone else, I updated the pom as follows:

          <artifactId>maven-surefire-plugin</artifactId>
            <configuration>
             <!-- Don't allow test to run for more than 30 minutes -->
              <forkedProcessTimeoutInSeconds>1800</forkedProcessTimeoutInSeconds>

This kills the test; however the output only reports the test class,
not the individual method, and the surefire report file is empty.

To get better info, add @Test(timeout=nnn) to all the likely culprits.

> - Brett
>
> --
> Brett Porter
> brett@apache.org
> http://brettporter.wordpress.com/
> http://au.linkedin.com/in/brettporter
>
>
>
>
>

Mime
View raw message