www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Laws <simonsl...@googlemail.com>
Subject Re: Tuscany Husdon build timeout while archiving artifacts
Date Mon, 11 Oct 2010 09:19:26 GMT
On Mon, Oct 11, 2010 at 10:16 AM, Niklas Gustavsson
<niklas@protocol7.com> wrote:
> On Mon, Oct 11, 2010 at 10:52 AM, Simon Laws <slaws@apache.org> wrote:
>> While our most recent builds are failing for legitimate reasons, when
>> the build runs further it fails due to a timeout as Hudson tries to
>> archive build artifacts, e.g. [1]. It seems to take a long time for
>> each archive step and fails when it tries to copy a large tar file.  I
>> looked to see if I could turn this archive step off but the "Archive
>> Artifacts" check box for the build is not selected as far a I can
>> tell. Our timeout is set to 400 which you would image would be
>> sufficient to copy some data. So anyone any idea...
>>
>> Why the archive step takes such a long time?
>
> There has been a bug in Hudson where the streams running over the
> socket to a slave would deadlock during archiving. This is supposed to
> be fixed in 1.380 which I deployed yesterday. Do you still see these
> problems after yesterday?

Not sure yet, I just fixed the problem that was otherwise causing the
build to fail. Running again. Will let you know.

>
>> Why is it doing it when it's apparently not enabled (is it forced by
>> one of the other selections we have)?
>
> Some archiving, if I understand things correctly, will be done by Hudson itself.

Ah Ok.

>
> /niklas
>

Simon

-- 
Apache Tuscany committer: tuscany.apache.org
Co-author of a book about Tuscany and SCA: tuscanyinaction.com

Mime
View raw message