www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler" <...@thetaphi.de>
Subject RE: Hudson Master's Clover parsing broken?
Date Tue, 19 Oct 2010 06:27:11 GMT
Hi,

Since yesterday morning the clover xml parsing is again sometimes broken on
master. Is this maybe an issue when transferring the file from the slave to
master?

Uwe

-----
Uwe Schindler
H.-H.-Meier-Allee 63, D-28213 Bremen
http://www.thetaphi.de
eMail: uwe@thetaphi.de

> -----Original Message-----
> From: Uwe Schindler [mailto:uwe@thetaphi.de]
> Sent: Wednesday, October 13, 2010 6:52 PM
> To: builds@apache.org
> Cc: dev@lucene.apache.org
> Subject: Hudson Master's Clover parsing broken?
> 
> Hi,
> 
> Sometimes (not always), but for our Clover-2.6.3-enabled Apache Solr
builds at
> least always, the final parsing of clover.xml seems to be broken on Hudson
> Master:
> 
> [TASKS] Scanning workspace files for tasks...
> Publishing Javadoc
> Archiving artifacts
> Recording test results
> Publishing Clover coverage report...
> Publishing Clover HTML report...
> Publishing Clover XML report...
> Publishing Clover coverage results...
> FATAL: Unable to copy coverage from
> /home/hudson/hudson-slave/workspace/Solr-
> trunk/checkout/solr/build/tests/clo
> ver/reports to
> /home/hudson/hudson/jobs/Solr-trunk/builds/2010-10-13_16-12-10
> hudson.util.IOException2: Cannot parse coverage results
> 	at
>
hudson.plugins.clover.CloverCoverageParser.parse(CloverCoverageParser.java:
> 8
> 9)
> 	at
>
hudson.plugins.clover.CloverCoverageParser.parse(CloverCoverageParser.java:
> 5
> 1)
> 	at
>
hudson.plugins.clover.CloverPublisher.processCloverXml(CloverPublisher.java:
> 202)
> 	at
> hudson.plugins.clover.CloverPublisher.perform(CloverPublisher.java:163)
> 	at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
> 	at
> hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:601)
> 	at
>
hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuil
> d
> .java:580)
> 	at
>
hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuil
> d
> .java:558)
> 	at hudson.model.Build$RunnerImpl.post2(Build.java:157)
> 	at
> hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:528)
> 	at hudson.model.Run.run(Run.java:1303)
> 	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
> 	at
> hudson.model.ResourceController.execute(ResourceController.java:88)
> 	at hudson.model.Executor.run(Executor.java:140)
> Caused by: org.xml.sax.SAXParseException: XML document structures must
> start and end within the same entity.
> 	at
>
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractS
> AXParser.java:1231)
> 	at
>
com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(S
> A
> XParserImpl.java:522)
> 	at org.apache.commons.digester.Digester.parse(Digester.java:1666)
> 	at
>
hudson.plugins.clover.CloverCoverageParser.parse(CloverCoverageParser.java:
> 8
> 7)
> 	... 13 more
> ERROR: Publisher hudson.plugins.clover.CloverPublisher aborted due to
> exception java.lang.NullPointerException
> 	at
> hudson.plugins.clover.CloverBuildAction.<init>(CloverBuildAction.java:133)
> 	at
> hudson.plugins.clover.CloverBuildAction.load(CloverBuildAction.java:265)
> 	at
>
hudson.plugins.clover.CloverPublisher.processCloverXml(CloverPublisher.java:
> 208)
> 	at
> hudson.plugins.clover.CloverPublisher.perform(CloverPublisher.java:163)
> 	at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
> 	at
> hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:601)
> 	at
>
hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuil
> d
> .java:580)
> 	at
>
hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuil
> d
> .java:558)
> 	at hudson.model.Build$RunnerImpl.post2(Build.java:157)
> 	at
> hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:528)
> 	at hudson.model.Run.run(Run.java:1303)
> 	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
> 	at
> hudson.model.ResourceController.execute(ResourceController.java:88)
> 	at hudson.model.Executor.run(Executor.java:140)
> Sending e-mails to: dev@lucene.apache.org
> Finished: FAILURE
> 
> Previously the Clover runs work perfectly. The downloaded clover.xml from
the
> workspace also looks fine and has definitely no XML parse errors. Maybe a
> network problem? I checked/rebooted everything, the only broken part seems
> the master...
> 
> What to do? Reboot? Upgrade? Thanks for looking after this!
> 
> Uwe
> 
> -----
> Uwe Schindler
> H.-H.-Meier-Allee 63, D-28213 Bremen
> http://www.thetaphi.de
> eMail: uwe@thetaphi.de
> 
> 



Mime
View raw message