www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gav..." <ga...@16degrees.com.au>
Subject RE: tomcat-trunk, tomcat-6-trunk (at buildslave3): cannot find javac compiler
Date Sun, 15 Aug 2010 16:30:15 GMT


> -----Original Message-----
> From: Konstantin Kolinko [mailto:knst.kolinko@gmail.com]
> Sent: Monday, 16 August 2010 1:12 AM
> To: builds@apache.org
> Subject: Re: tomcat-trunk, tomcat-6-trunk (at buildslave3): cannot find
> javac compiler
> 
> No luck here.  It is still failing.
> 
> http://ci.apache.org/builders/tomcat-trunk/builds/376
> Aug 15 14:49  - that is 30 minutes ago.

Hi,

After the OS upgrade from 9.04 to 10.04 it loses the Sun JDK. I've just
reinstalled it,
next build should be fine, if not I'll take another look in the morning.

Gav...

> 
> Best regards,
> Konstantin Kolinko
> 
> 2010/8/14 Jacques Le Roux <jacques.le.roux@les7arts.com>:
> > We got the same recently with OFBiz, but on a sole fail report, then
> all got
> > fine again...
> >
> > HTH
> >
> > Jacques
> >
> > From: "Konstantin Kolinko" <knst.kolinko@gmail.com>
> >>
> >> Hi!
> >>
> >> The following builders started to fail recently:
> >>
> >> http://ci.apache.org/builders/tomcat-trunk/
> >> http://ci.apache.org/builders/tomcat-6-trunk/
> >>
> >> The stdio log files show the message that Ant cannot find the javac
> >> compiler. E.g., this one:
> >>
> >> http://ci.apache.org/builders/tomcat-6-
> trunk/builds/80/steps/compile_1/logs/stdio
> >>
> >> 1) First, when launching ant:
> >>>
> >>> Unable to locate tools.jar. Expected to find it in
> >>> /usr/lib/jvm/java-6-sun-1.6.0.20/lib/tools.jar
> >>
> >> 2) Second,
> >>>
> >>> BUILD FAILED
> >>> /home/buildslave3/slave3/tomcat-6-trunk/build/build.xml:149: Unable
> to
> >>> find a javac compiler;
> >>> com.sun.tools.javac.Main is not on the classpath.
> >>> Perhaps JAVA_HOME does not point to the JDK.
> >>> It is currently set to "/usr/lib/jvm/java-6-sun-1.6.0.20/jre"
> >>
> >> Comparing stdio of failed build 80 with previous successful build
> 79,
> >>
> >> http://ci.apache.org/builders/tomcat-6-
> trunk/builds/80/steps/compile_1/logs/stdio
> >>
> >> http://ci.apache.org/builders/tomcat-6-
> trunk/builds/79/steps/compile_1/logs/stdio
> >>
> >> looking at the environment listing at the start of the stdio files,
> >> neither has JAVA_HOME defined,  but there are some differences in
> >> other environment variables (LANG not defined and different value of
> >> PATH)
> >>
> >> Can someone correct misconfiguration that causes the builds to fail?
> >>
> >> Last successful builds were on August 6th.  First failing builds
> >> occurred on August 11th.
> >>
> >> Best regards,
> >> Konstantin Kolinko
> >>
> >
> >



Mime
View raw message