www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler" <...@thetaphi.de>
Subject RE: [Hudson] Problem with jobs tied to slave names
Date Tue, 17 Aug 2010 08:22:26 GMT
Hi Niklas,

I solved this for Lucene/Solr by adding a label "lucene" to our slave and
entered the label in the input field of the job. This works fine. Using
labels for slaves is a good thing as you can group them. E.g. All builds of
Hadoop only run on any slave that has hadoop label or similar.

The only strange thing: since today, I have no longer access to the slave
settings?

Uwe

-----
Uwe Schindler
H.-H.-Meier-Allee 63, D-28213 Bremen
http://www.thetaphi.de
eMail: uwe@thetaphi.de

> -----Original Message-----
> From: Niklas Gustavsson [mailto:niklas@protocol7.com]
> Sent: Tuesday, August 17, 2010 9:36 AM
> To: builds@apache.org
> Subject: [Hudson] Problem with jobs tied to slave names
> 
> Hi
> 
> In the latest version of Hudson, which we are running, they added boolean
> expression support when tying a job to a slave/label. The expression
language
> uses parenthesis. So does our slave names. This has caused some job
> configurations to fail, e.g. when using the string "minerva.apache.org
(Ubuntu)"
> (claiming this is an invalid expression). I've opened an issue in the
Hudson JIRA
> to see if parenthesis in slave names are now invalid. If so, we might have
to
> rename our slaves. In the short term, I'll keep an eye on any further
problems
> in our setup caused by this (I've fixed a few cases so far).
> 
> /niklas


Mime
View raw message