www-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Ellison <t.p.elli...@gmail.com>
Subject Re: 2 hudson questions
Date Tue, 24 Nov 2009 14:28:57 GMT
On 23/Nov/2009 18:22, Andreas Andreou wrote:
> Tapestry recently started using hudson.zones.apache.org for its builds
> and here are 2 issues i've encountered:
> 1) I was told to pin the build to the vesta slave but it looks like it's
> missing maven - am i supposed to install maven for the hudson user
> on my own ? I can certainly do that, just want to make sure it's ok
> to do so (for now, i've just configured the builds to use the master node)

I see Maven on there, in /home/hudson/tools/maven

Are you defining a Hudson maven build, or trying to invoke mvn directly?

> 2) Is anyone running selenium tests from those hudson slaves?

Sorry, don't know.

> Our builds do include such tests, and it'd be great to have them
> running but right now i see a "Failed to start new browser session: 
> java.lang.RuntimeException: Firefox 3 could not be found in the
> path!" error message... So, again, what should be the best course of 
> action in order to go forward with this?

Do you have an idea of what you need?  I have zero experience of
selenium, but if it needs to drive a UI then I assume you'll need Xvfb
[1] etc.

> fyi, i've also sent an email about issue 1) to hudson@hudson.zones.apache.org
> but i never got any feedback - is there another list i should send this to?

That should have worked.  I've added myself and Jukka to that alias so
hopefully somebody will see it; though the response might just be to
post here though <g>


[1] Word to the wise, the Xvfb package dependencies appear to be a bit
lacking, you also need to install a rendering engine or else the log
file gets a bit big {ahem} :-)

Regards,
Tim

Mime
View raw message