www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Larry Rosenman <...@lerctr.org>
Subject Re: build/9937: After updating config.guess and config.sub, and the libtool.m4, I can't install.
Date Tue, 26 Feb 2002 13:27:48 GMT

* jerenkrantz@apache.org <jerenkrantz@apache.org> [020226 02:33]:
> [In order for any reply to be added to the PR database, you need]
> [to include <apbugs@Apache.Org> in the Cc line and make sure the]
> [subject line starts with the report component and number, with ]
> [or without any 'Re:' prefixes (such as "general/1098:" or      ]
> ["Re: general/1098:").  If the subject doesn't match this       ]
> [pattern, your message will be misfiled and ignored.  The       ]
> ["apbugs" address is not added to the Cc line of messages from  ]
> [the database automatically because of the potential for mail   ]
> [loops.  If you do not include this Cc, your reply may be ig-   ]
> [nored unless you are responding to an explicit request from a  ]
> [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
> 
> 
> Synopsis: After updating config.guess and config.sub, and the libtool.m4, I can't install.
> 
> State-Changed-From-To: open-closed
> State-Changed-By: jerenkrantz
> State-Changed-When: Tue Feb 26 00:33:33 PST 2002
> State-Changed-Why:
> Since these changes are not related to any ASF software,
> there isn't a lot we can do.  It sounds like these
> changes need to be merged into the GNU toolchain.
You need to update at least the config.guess and config.sub to the
latest versions to even have a prayer of configuring on OpenUNIX 8.
> 
> However, in order to assure the least amount of
> problems for our source distributions, we only use
> stable versions of autoconf and libtool.  Apparently,
> later versions (2.5+) of autoconf do not work on HP-UX,
> so we may just state that OpenUnix users require the
> latest autoconf/libtool versions and need to run
> buildconf on their own.
I could NOT even get it to INSTALL, so there is SOMETHING wrong. 

Why was this closed without even asking me for an account??
> 
> What is unclear from your PR is whether the libtool
> changes fixed your problem.  Or, does OpenUnix not
> use a .so extension for its libraries?
NO, there were other changes to get the dependencies right, and we
DIDN'T get it built right....
> 
> (Your config.status is semi-invalid for 2.0, FWIW.)
What needs to change?
> Severity-Changed-From-To: critical-non-critical
> Severity-Changed-By: jerenkrantz
> Severity-Changed-When: Tue Feb 26 00:33:33 PST 2002

-- 
Larry Rosenman                     http://www.lerctr.org/~ler
Phone: +1 972-414-9812                 E-Mail: ler@lerctr.org
US Mail: 1905 Steamboat Springs Drive, Garland, TX 75044-6749

Mime
View raw message