www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Wies <w...@wiessoft.de>
Subject os-windows/9863: Installation process windows
Date Mon, 18 Feb 2002 19:35:01 GMT

>Number:         9863
>Category:       os-windows
>Synopsis:       Installation process windows
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Mon Feb 18 11:40:00 PST 2002
>Closed-Date:
>Last-Modified:
>Originator:     wies@wiessoft.de
>Release:        2.0.32-beta-win32-x86-no_ssl.msi
>Organization:
apache
>Environment:
NT4, SP6a, post6aSRP, MSI20
nothing else, completely new os installation
>Description:
after a 'successful' installation, apache is not registered as service.
the monitor is running and shows no installed services.
the shortcuts in startup->apache->config and startup->apache->control
are created but they doesnt work.

first, the shortcut 'Test Configuration' contains '-w' which is unknown
('Apache.exe: illegal option -- w'). after removing '-w' apache.exe 
terminates with an access violation.

the shortcuts for 'Restart', 'Start' and 'Stop' uses '-n "Apache2"' which
refers to the uninstalled service.
>How-To-Repeat:

>Fix:
if it is intended that the service is not registered by the installer
please show a message to inform the user. a message indicating a successful
installation is very misleading

implement '-w' or remove it (sorry, i am not familiar with the source code)

i removed '-d "c:\program files\....\Apache2\"' to avoid the crash. it looks
to me that it is a problem with the last '\'

btw. please correct the download path for MSI in the documentation. it still
points to version 1.10 but 2.0 is available for a while
http://www.microsoft.com/downloads/release.asp?ReleaseID=32832
>Release-Note:
>Audit-Trail:
>Unformatted:
 [In order for any reply to be added to the PR database, you need]
 [to include <apbugs@Apache.Org> in the Cc line and make sure the]
 [subject line starts with the report component and number, with ]
 [or without any 'Re:' prefixes (such as "general/1098:" or      ]
 ["Re: general/1098:").  If the subject doesn't match this       ]
 [pattern, your message will be misfiled and ignored.  The       ]
 ["apbugs" address is not added to the Cc line of messages from  ]
 [the database automatically because of the potential for mail   ]
 [loops.  If you do not include this Cc, your reply may be ig-   ]
 [nored unless you are responding to an explicit request from a  ]
 [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
 
 


Mime
View raw message