www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rexon Philip <rexon_phi...@hp.com>
Subject protocol/9809: connect_to_tomcat, failed errno = 61
Date Wed, 13 Feb 2002 10:28:26 GMT

>Number:         9809
>Category:       protocol
>Synopsis:       connect_to_tomcat, failed errno = 61
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          support
>Submitter-Id:   apache
>Arrival-Date:   Wed Feb 13 02:30:01 PST 2002
>Closed-Date:
>Last-Modified:
>Originator:     rexon_philip@hp.com
>Release:        1.3.23
>Organization:
apache
>Environment:
OS:Windows NT Service Pack 5 
Version of Apache release :1.3.23
(apache_1.3.23-win32-x86-no_src.exe)
>Description:
Hi,
   My name is Rexon , working for Hewlett-Packard. I got a quick question on Tomcat + Apache,
Could you please help me to clarify error occured in mod_jk.log.

I had installed Tomcat 3.3a + Apache 1.3.23 on WinNT OS Service Pack 5. 

Configuration settings
------------------------


workers.properties:
------------------------
worker.ajp13.port=8009
worker.ajp13.host=localhost
worker.ajp13.type=ajp13


Server.xml
------------
<Ajp13Connector port="8009" />


prof-server.xml
----------------
<RequestInterceptor 
className="org.apache.ajp.tomcat33.Ajp13Interceptor"
address="127.0.0.1"
port="8009" />


wrappers.properties
---------------------
wrapper.shutdown_port=8009
wrapper.shutdown_protocol=ajp13


tomcat.conf 
--------------
ApJServManual off

tomcat.properties
---------------------
# Set the port Apache JServ listens to.
# Syntax: port=[1024,65535] (int)
# Default: 8007
port=8009




mod_jk.log
-----------
[jk_connect.c (143)]: jk_open_socket, connect() failed errno = 61
[jk_ajp13_worker.c (196)]: In jk_endpoint_t::connect_to_tomcat, failed errno=61
[jk_ajp13_worker.c (635)]: Error connecting to the Tomcat process.


Everything works fine, if Tomcat & Apache started seperately. I think I had done all settings,
Apache does'nt start Tomcat due to socket error.


Thanks a lot,

Regards,
Rexon 



>How-To-Repeat:
Configure Apache to start Tomcat.
>Fix:

>Release-Note:
>Audit-Trail:
>Unformatted:
 [In order for any reply to be added to the PR database, you need]
 [to include <apbugs@Apache.Org> in the Cc line and make sure the]
 [subject line starts with the report component and number, with ]
 [or without any 'Re:' prefixes (such as "general/1098:" or      ]
 ["Re: general/1098:").  If the subject doesn't match this       ]
 [pattern, your message will be misfiled and ignored.  The       ]
 ["apbugs" address is not added to the Cc line of messages from  ]
 [the database automatically because of the potential for mail   ]
 [loops.  If you do not include this Cc, your reply may be ig-   ]
 [nored unless you are responding to an explicit request from a  ]
 [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
 
 


Mime
View raw message