www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shravan Shashikant <shrav...@tamu.edu>
Subject os-windows/8760: Apache 1.3.20 hangs on Windows 2000
Date Thu, 15 Nov 2001 07:43:23 GMT

>Number:         8760
>Category:       os-windows
>Synopsis:       Apache 1.3.20 hangs on Windows 2000
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Wed Nov 14 23:50:00 PST 2001
>Closed-Date:
>Last-Modified:
>Originator:     shravans@tamu.edu
>Release:        1.3.20
>Organization:
apache
>Environment:
Windows 2000
>Description:
I have the Apache 1.3.20 http server running on a Windows 2000 m/c..When it is started it
works fine but after sometime it just hangs and even restart doesnt work at times.. We need
to do stop the service and then start it again. The error log has the following information
:
[Thu Nov 15 01:21:43 2001] [error] (22)Invalid argument: accept: (client socket) failed with
errno = 10022
[Thu Nov 15 01:24:41 2001] [error] (22)Invalid argument: accept: (client socket) failed with
errno = 10022
[Thu Nov 15 01:25:04 2001] [error] (22)Invalid argument: accept: (client socket) failed with
errno = 10022
[Thu Nov 15 01:36:58 2001] [error] (22)Invalid argument: accept: (client socket) failed with
errno = 10022
>How-To-Repeat:
I found that primarily the problem lies in the NT session. When I log in to my machine,the
Apache server suddenly hangs, I then restart it, and then it works fine even when I logout,
but when i login in again it hangs. This is one way in which i could repeat the problem.Hope
it helps.
 There's a bug already reported (PR#8473) but i found no way in which i could add a comment
to that,to make life easier for the apache developers as well as me.The bug reporter has a
similar configuration and problem as mine but wasnt able to repeat the problem with much success.
Ideally a comment there wud have been much more efficient for tracking and solving.
>Fix:

>Release-Note:
>Audit-Trail:
>Unformatted:
 [In order for any reply to be added to the PR database, you need]
 [to include <apbugs@Apache.Org> in the Cc line and make sure the]
 [subject line starts with the report component and number, with ]
 [or without any 'Re:' prefixes (such as "general/1098:" or      ]
 ["Re: general/1098:").  If the subject doesn't match this       ]
 [pattern, your message will be misfiled and ignored.  The       ]
 ["apbugs" address is not added to the Cc line of messages from  ]
 [the database automatically because of the potential for mail   ]
 [loops.  If you do not include this Cc, your reply may be ig-   ]
 [nored unless you are responding to an explicit request from a  ]
 [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
 
 


Mime
View raw message