www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Hoffman <andy.hoff...@bms.com>
Subject general/8578: Form "POST" extremely slow from localhost
Date Thu, 18 Oct 2001 16:15:36 GMT

>Number:         8578
>Category:       general
>Synopsis:       Form "POST" extremely slow from localhost
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Thu Oct 18 09:20:01 PDT 2001
>Closed-Date:
>Last-Modified:
>Originator:     andy.hoffman@bms.com
>Release:        1.3.20 (also seen in 1.3.19)
>Organization:
apache
>Environment:
Win2000 Professional SP1
Apache 1.3.20 pre-built release from apache.org
Netscape Navigator 4.72
IE 5.5
>Description:
Related to bug #7623 - no feasible resolution was found there...

When submitting html forms with a "post" method to server via 
Netscape Navigator (4.72) on localhost machine, the server takes
a VERY long time to process the form (in excess of 15 seconds),
no matter how simple or complicated the form or processing may
be on the server end.

A few observations... 

1) This problem does not occur when accessed
via IE 5.5 on localhost - the form is processed in normal time. 
2) The problem does not occur if the form is submitted using a
"get" method, in both Netscape and IE.
3) Problem does not occur when accessed from other machines on
local network (non-localhost access).
4) I don't believe the problem occured under WinNT with same
browser and Apache versions... seems to be combo of Win2000,
Netscape 4.7x and Apache 1.3.20(also 19).
5) We have seen the same problem occur on 3 separate machines, each
running Win2000, with default Apache 1.3.20 installations (only
addition is Jakarta 3.2.x - removing Jakarta does not clear up the
issue either)
6) Server-side CGI processing language (who's handling the request)
does not appear to matter... same behavior noticed in JSP, PHP, and
Perl.

I would use a GET method in the form, however the data I need to
process is larger than the maximum "get" URL length, so I must use
a form POST method.
>How-To-Repeat:
Install Apache 1.3.20 on a Win2000 computer.
Install Netscape Navigator 4.72.
Create a simple form with a "post" method.
Process the form (and generate response) through Perl.
Access the same form through IE and note the extreme speed difference.
>Fix:

>Release-Note:
>Audit-Trail:
>Unformatted:
 [In order for any reply to be added to the PR database, you need]
 [to include <apbugs@Apache.Org> in the Cc line and make sure the]
 [subject line starts with the report component and number, with ]
 [or without any 'Re:' prefixes (such as "general/1098:" or      ]
 ["Re: general/1098:").  If the subject doesn't match this       ]
 [pattern, your message will be misfiled and ignored.  The       ]
 ["apbugs" address is not added to the Cc line of messages from  ]
 [the database automatically because of the potential for mail   ]
 [loops.  If you do not include this Cc, your reply may be ig-   ]
 [nored unless you are responding to an explicit request from a  ]
 [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
 
 


Mime
View raw message