www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Slemko <ma...@znep.com>
Subject Re: general/8014: mod_rewrite translation doesn't work for html page references
Date Fri, 13 Jul 2001 19:30:11 GMT
The following reply was made to PR general/8014; it has been noted by GNATS.

From: Marc Slemko <marcs@znep.com>
To: Dave_Melling <Dave_Melling@hotmail.com>
Cc: marc@apache.org, apbugs@apache.org
Subject: Re: general/8014: mod_rewrite translation doesn't work for html page
 references
Date: Fri, 13 Jul 2001 12:24:02 -0700 (PDT)

 On Fri, 13 Jul 2001, Dave_Melling wrote:
 
 > Hi Marc,
 > 
 > Thanks for the information but now I'm really confused.  From your response
 > I gather the following happens:
 > 
 > 1)  My browser requests a document.
 > 2)  The server remaps the URL.
 > 3)  The server returns the document.
 > 4)  My browser parses the document and comes across a reference to an image
 > which it requests.
 > 5)  This time the server does not remap the URL so the image is not
 > returned.
 > 
 > The URL request format is the same in both cases.  From your mail it sounds
 > like they are separate requests from the browser so why does the first work
 > and the second fail?
 
 Then obviously the "request format" isn't the same.  Figure out what URL
 your browser is trying to use to load the image that isn't working.  Then
 figure out why your rewrite rules aren't applying to that URL, and fix
 them so they do.  I'm afraid we really can't help explain how the web
 works here, this forum is for bug reports and we do not have the resources
 to tutor people.
 
 > 
 > I have been looking on the web for information on browser/server
 > communication and more specific details about their internal workings but
 > haven't found anything yet.  If you know of any references I would happy if
 > you could forward them so I can work out what's going on.
 > 
 > 
 > Cheers,
 > 
 > Dave
 > 
 > ----- Original Message -----
 > From: <marc@apache.org>
 > To: <apache-bugdb@apache.org>; <dave_melling@hotmail.com>; <marc@apache.org>
 > Sent: Thursday, July 12, 2001 6:56 PM
 > Subject: Re: general/8014: mod_rewrite translation doesn't work for html
 > page references
 > 
 > 
 > > [In order for any reply to be added to the PR database, you need]
 > > [to include <apbugs@Apache.Org> in the Cc line and make sure the]
 > > [subject line starts with the report component and number, with ]
 > > [or without any 'Re:' prefixes (such as "general/1098:" or      ]
 > > ["Re: general/1098:").  If the subject doesn't match this       ]
 > > [pattern, your message will be misfiled and ignored.  The       ]
 > > ["apbugs" address is not added to the Cc line of messages from  ]
 > > [the database automatically because of the potential for mail   ]
 > > [loops.  If you do not include this Cc, your reply may be ig-   ]
 > > [nored unless you are responding to an explicit request from a  ]
 > > [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
 > >
 > >
 > > Synopsis: mod_rewrite translation doesn't work for html page references
 > >
 > > State-Changed-From-To: open-closed
 > > State-Changed-By: marc
 > > State-Changed-When: Thu Jul 12 09:56:12 PDT 2001
 > > State-Changed-Why:
 > > The browser is the one that requests the images.  You either need to have
 > the server send a redirect (instead of just an internal rewrite) so the
 > client knows how to resolve the relative URLs properly, or you have to add
 > more rewrite rules so when the browser requests the images the requests will
 > be rewritten to where they really are.
 > >
 > > Apache does not parse the HTML or send the images, the client parses the
 > HTML and requests the images.
 > >
 > >
 > 
 

Mime
View raw message