www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Usman Wahid <mswa...@yahoo.com>
Subject general/7603: Server hanging when faced with network bottlenecks
Date Sun, 22 Apr 2001 07:43:01 GMT

>Number:         7603
>Category:       general
>Synopsis:       Server hanging when faced with network bottlenecks
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Sun Apr 22 00:50:00 PDT 2001
>Closed-Date:
>Last-Modified:
>Originator:     mswahid@yahoo.com
>Release:        1.3.12
>Organization:
apache
>Environment:
Linux 2.2.12-20smp #1 SMP i686 (RedHat Linux 6.1)
>Description:
we have a redhat linux 6.1 server running Apache 1.3.12 using mod_perl. the site is very busy
but works normal when it is accessible from external network. the problem is when a major
part of internet can't connect to the server properly (at normal speed) the apache seems to
hang and doesn't respond. the surprising thing is that at that time apache doesn't respond
even if we connect from local host. if we try to restart apache or the server it remains okay
for a few seconds but then again it seems to hang from local host. probably it is due to the
fact that immediately after restarting there are many requests for apache. we are also using
nmap to scan local ports and at the time of hanging of apache, port 80 is shown as filtered.
there are no errors in server logs. the settings are: MinSpareServers 20, MaxSpareServers
40, StartServers 30, Maxclients 300 and MaxRequestsPerchild 0. the question is why we can't
connect from the localhost when httpd restarts okay without any errors and there is no change
in the configuration. the most surprising thing is that things are back to normal when there
is no network problem.
>How-To-Repeat:

>Fix:

>Release-Note:
>Audit-Trail:
>Unformatted:
 [In order for any reply to be added to the PR database, you need]
 [to include <apbugs@Apache.Org> in the Cc line and make sure the]
 [subject line starts with the report component and number, with ]
 [or without any 'Re:' prefixes (such as "general/1098:" or      ]
 ["Re: general/1098:").  If the subject doesn't match this       ]
 [pattern, your message will be misfiled and ignored.  The       ]
 ["apbugs" address is not added to the Cc line of messages from  ]
 [the database automatically because of the potential for mail   ]
 [loops.  If you do not include this Cc, your reply may be ig-   ]
 [nored unless you are responding to an explicit request from a  ]
 [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
 
 


Mime
View raw message