www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jens Grubert <gj...@web.de>
Subject os-windows/7563: failed to load the php4 module
Date Sat, 14 Apr 2001 23:53:23 GMT

>Number:         7563
>Category:       os-windows
>Synopsis:       failed to load the php4 module
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   unknown
>Arrival-Date:   Sat Apr 14 17:00:00 PDT 2001
>Closed-Date:
>Last-Modified:
>Originator:     gjens@web.de
>Release:        1.3.19
>Organization:
apache
>Environment:
windows 2000 professional
php version 4.0.4pl1
apache version 1.3.19
>Description:
I installed Apache 1.3.19 and php4.0.4pl1 on Win2k and
tried to load the php4 module into the apache service.
entry in the httpd.conf:
"LoadModule php4_module h:\php\sapi\php4apache.dll"

But the Service cannot start.
error message:
------------------
Syntax error in line 205 of h:/apache/conf/httpd/conf
Cannot load h:\php\sapi\php4apache.dll into server: (127) The give Procedure wasn´t found
--------------------
(translated)
The German original message:
-------------------
Syntax error in line 205 of h:/apache/conf/httpd/conf
Cannot load h:\php\sapi\php4apache.dll into server: (127) Die angegebene prozedur wurde nicht
gefunden
--------------------

I exchanged the php4apache.dll from the distribution "php4.0.4pl1" with the one out of 
"php4.0.4-dev". Then the error message didn't appear, but the service cannot start as well!

The same php module is working under Apache 1.3.14 for windows. 

I downloaded the php4.0.4pl1 distribution from php.net, and loaded no modules, the php.exe
can start without problems as standalone programm.

(Before this installation i had running:
apache 1.3.14 and php4.0.4-dev, but had different difficultieswith that release )

Jens Grubert
germany
>How-To-Repeat:
trie to load the "php4apache.dll" (php4.0.4pl1) into apache 1.3.19 for windows
under win2k 
>Fix:
no
>Release-Note:
>Audit-Trail:
>Unformatted:
 [In order for any reply to be added to the PR database, you need]
 [to include <apbugs@Apache.Org> in the Cc line and make sure the]
 [subject line starts with the report component and number, with ]
 [or without any 'Re:' prefixes (such as "general/1098:" or      ]
 ["Re: general/1098:").  If the subject doesn't match this       ]
 [pattern, your message will be misfiled and ignored.  The       ]
 ["apbugs" address is not added to the Cc line of messages from  ]
 [the database automatically because of the potential for mail   ]
 [loops.  If you do not include this Cc, your reply may be ig-   ]
 [nored unless you are responding to an explicit request from a  ]
 [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
 
 


Mime
View raw message