www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Melin <jme...@widget.winternet.com>
Subject apache-api/7258: <!--#exec cgi="/cgi-bin/Testexec.rexx" --> call in the body of a web page fails to execute script where as http://{server}/cgi-bin/Testexec.rexx works fine.
Date Fri, 16 Feb 2001 17:09:42 GMT

>Number:         7258
>Category:       apache-api
>Synopsis:       <!--#exec cgi="/cgi-bin/Testexec.rexx" --> call in the body of a
web page fails to execute script where as http://{server}/cgi-bin/Testexec.rexx works fine.
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Fri Feb 16 09:10:01 PST 2001
>Closed-Date:
>Last-Modified:
>Originator:     jmelin@widget.winternet.com
>Release:        1.314
>Organization:
apache
>Environment:
Windows NT Workstation service pack 6 - Also occurrs on Windows 2000 Professional Service
pack 1
>Description:
No dumps. Nothing in Error log. Access log shows only the page with the issue in it. Specifically
the call is http://[server}:8080/{subdir}/{webpage}

That page contains:
<html>

<head>
<title>Apache Test Page</title>
<base target="main">
</head>

<body>
<pre>
This is a test of explicit CGI call via exec CGI
</pre>
<!--#exec cgi="/cgi-bin/Testexec2.rexx"  -->
</body>
</html>

Also have tried the exec as <!--#exec cgi="Testexec2.rexx"  -->

The HTTPD.conf file is pretty much default values except for server name and the ScriptInterpreterSource
directive being turned on/off

I am using the Regina Rexx interpreter (available at http://www.lightlink.com/hessling/Regina/index.html),
and I am encountering this error with both the ScriptInterpreterSource registry directive
commented out and enabled.

The REXX exec is very simple. IT looks like this:
{#!E:/Regina/regina.exe - is the shebang line used when ScriptInterpreterSource is commented
out)

/* rexx */
say "Content-type: text/html"
say
say '<H1>Hello, World!</H1>'
exit
>How-To-Repeat:
Please mail me for the specific URL to test this - as I do not want the entire universe playing
with this server. 

Please note, I DID look through the bug list and didn't find anything that seemed to fit this
particular problem. I saw stuff with perl scripts not accepting parameters etc. But this seemed
a bit less complex than that. This problem is 'serious' from my perspective as it is preventing
me from doing things in the simplest way possible. I could write everything to be server generated
as the particular application is small, and invoke the main script via a meta refresh tag
in a default page but I'd rather not do that if there is a fix
>Fix:
Um, I wish I did :)
>Release-Note:
>Audit-Trail:
>Unformatted:
 [In order for any reply to be added to the PR database, you need]
 [to include <apbugs@Apache.Org> in the Cc line and make sure the]
 [subject line starts with the report component and number, with ]
 [or without any 'Re:' prefixes (such as "general/1098:" or      ]
 ["Re: general/1098:").  If the subject doesn't match this       ]
 [pattern, your message will be misfiled and ignored.  The       ]
 ["apbugs" address is not added to the Cc line of messages from  ]
 [the database automatically because of the potential for mail   ]
 [loops.  If you do not include this Cc, your reply may be ig-   ]
 [nored unless you are responding to an explicit request from a  ]
 [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
 
 


Mime
View raw message