www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Terrell Larson <t...@terralogic.net>
Subject config/7204: apxs is not correctly generated from apxs.pl (variables missing)
Date Tue, 06 Feb 2001 07:02:53 GMT

>Number:         7204
>Category:       config
>Synopsis:       apxs is not correctly generated from apxs.pl (variables missing)
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Mon Feb 05 23:10:00 PST 2001
>Closed-Date:
>Last-Modified:
>Originator:     terr@terralogic.net
>Release:        1.3.14 (with openssl)
>Organization:
apache
>Environment:
Red hat Linux 6.1
>Description:
In my installation the follow is found in apxs after make install:

y $CFG_TARGET        = q(httpsd);            # substituted via Makefile.tmpl
my $CFG_CC            = q(gcc);                # substituted via Makefile.tmpl
my $CFG_CFLAGS        = q( -DLINUX=2 -DTARGET="httpsd" -DUSE_HSREGEX -DUSE_EXPAT -I../lib/expat-lite
-DNO_DL_NEEDED -DAPACHE_SSL `../apaci`);
        # substituted via Makefile.tmpl
my $CFG_CFLAGS_SHLIB  = q();      # substituted via Makefile.tmpl
my $CFG_LD_SHLIB      = q();          # substituted via Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = q(); # substituted via Makefile.tmpl
my $CFG_LIBS_SHLIB    = q();        # substituted via Makefile.tmpl

This means the following variables were not set when configure got there... 
CFLAGS_SHLIB  LD_SHLIB LDFLAGS_MOD_SHLIB LIBS_SHLIB
my $CFG_PREFIX        = q(/usr/local/apache-1.3.14);            # substituted via APACI install
my $CFG_SBINDIR       = q(/usr/local/apache-1.3.14/bin);           # substituted via APACI
install
my $CFG_INCLUDEDIR    = q(/usr/local/apache-1.3.14/include);        # substituted via APACI
install
my $CFG_LIBEXECDIR    = q(/usr/local/apache-1.3.14/libexec);        # substituted via APACI
install
my $CFG_SYSCONFDIR    = q(/usr/local/apache-1.3.14/conf);        # substituted via APACI install
>How-To-Repeat:
I don't know if you can repeat it by I suspect so.  

I down loaded Ben Laurie's tarball - apache_1.3.14+openssl_1.42 adn built it against openssl_0.9.6
>Fix:
I can try to go through the autoconf and configuration if and fix this if someone who is more
familiar can give me some idea where to start.

Also - I can place the tarballs in the anon ftp server.

Finally - if someone can give me an idea what these variables should be set to I'll just fix
my copy for now.  This won't set me back for long.
>Release-Note:
>Audit-Trail:
>Unformatted:
 [In order for any reply to be added to the PR database, you need]
 [to include <apbugs@Apache.Org> in the Cc line and make sure the]
 [subject line starts with the report component and number, with ]
 [or without any 'Re:' prefixes (such as "general/1098:" or      ]
 ["Re: general/1098:").  If the subject doesn't match this       ]
 [pattern, your message will be misfiled and ignored.  The       ]
 ["apbugs" address is not added to the Cc line of messages from  ]
 [the database automatically because of the potential for mail   ]
 [loops.  If you do not include this Cc, your reply may be ig-   ]
 [nored unless you are responding to an explicit request from a  ]
 [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
 
 


Mime
View raw message