www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tobias Wiersch <sw...@mindless.com>
Subject mod_digest/7017: Digest auth scheme not working with IE5.5 ?
Date Fri, 29 Dec 2000 00:29:19 GMT

>Number:         7017
>Category:       mod_digest
>Synopsis:       Digest auth scheme not working with IE5.5 ?
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Thu Dec 28 16:30:00 PST 2000
>Closed-Date:
>Last-Modified:
>Originator:     swift@mindless.com
>Release:        1.3.14-win32
>Organization:
apache
>Environment:
WinMe, standard Win32 binaries
Using local installation (on 127.0.0.1)
>Description:
I don't found an entry for this problem in the report database ...

IE5 should support the digest auth-scheme (as written in the docs).
I made two user-password-files (users.digest and users.basic with htdigest.exe/htpasswd.exe)

When I use:
<Location /admin/>
  AuthType Basic
  AuthName "xxx"
  AuthUserFile d:/3dx/users.basic
  Require valid-user
</Location>

everything works fine with IE5.5 and Navigator. IE5.5 and Navigator will both ask for username
and password and if they are correct, Apache will let me in.
I used the URL http://127.0.0.1/admin/test.htm, for example.

But when I use instead:
<Location /admin/>
  AuthType Digest
  AuthName "xxx"
  AuthDigestFile d:/3dx/users.digest
  Require valid-user
</Location>

I can't login with Navigator - ok, that's normal because Navigator doesn't support Digest.
(Navigator asks me nevertheless for username/password and the apache-error-log tells me correctly
"client used wrong authentication scheme: ...")
BUT: when calling the same page with IE5.5, I will get an "The page cannot be displayed (cannot
find server)"-error!
There is no entry in the Apache error-log for this call!
I can call any page outside the /admin/-directory with IE5.5 but I will get the error when
calling any file IN the directory (when using the Digest-scheme instead of the Basic-scheme).

A snippet from my httpd.conf:
#LoadModule digest_auth_module modules/ApacheModuleAuthDigest.dll
#LoadModule cern_meta_module modules/ApacheModuleCERNMeta.dll
LoadModule digest_module modules/ApacheModuleDigest.dll

I'm wondering if I have to enable the first line? But there is no ApacheModuleAuthDigest.dll
in the Apache1.3.14-distribution!?

What must I do to fix this problem? Thanks for your help!
>How-To-Repeat:

>Fix:

>Release-Note:
>Audit-Trail:
>Unformatted:
 [In order for any reply to be added to the PR database, you need]
 [to include <apbugs@Apache.Org> in the Cc line and make sure the]
 [subject line starts with the report component and number, with ]
 [or without any 'Re:' prefixes (such as "general/1098:" or      ]
 ["Re: general/1098:").  If the subject doesn't match this       ]
 [pattern, your message will be misfiled and ignored.  The       ]
 ["apbugs" address is not added to the Cc line of messages from  ]
 [the database automatically because of the potential for mail   ]
 [loops.  If you do not include this Cc, your reply may be ig-   ]
 [nored unless you are responding to an explicit request from a  ]
 [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
 
 


Mime
View raw message