www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Neish <richardne...@email.com>
Subject mod_jserv/6486: mod_jserv returns no data intermittently on SCO OpenServer
Date Thu, 31 Aug 2000 00:37:05 GMT

>Number:         6486
>Category:       mod_jserv
>Synopsis:       mod_jserv returns no data intermittently on SCO OpenServer
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    jserv
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Wed Aug 30 17:40:01 PDT 2000
>Closed-Date:
>Last-Modified:
>Originator:     richardneish@email.com
>Release:        Apache/1.3.12 (Unix)
>Organization:
apache
>Environment:
SCO_SV servername 3.2 5.0.5 i386
SCO UNIX Development System  Release 5.1.1A 27Jul98
Java Development Kit 1.1.7B for SCO Operating Systems
UDK Compatibility Module for OpenServer 5.0.5 (ver 5.0.5A)
Java(tm) Servlet Development Kit (JSDK) 2.0
Apache 1.3.12 compiled from source
ApacheJServ 1.1.2 compiled from source
>Description:
The sample output below shows the result of seven (7) connection attempts from a client computer.
 Three (3) attempts return the servlet output, while the other four(4) return no data.  The
equivalent configuration works on RedHat 6.2, but not with SCO.  The problem exists with ApacheJServ
1.1.2 and 1.1.1

----Start of sample output-----
 client:~ % lynx -source http://servername/servlets/Hello
<HTML><HEAD><TITLE>
Example Apache JServ Servlet
</TITLE></HEAD><BODY bgcolor="#FFFFFF">
<H1>Example Apache JServ Servlet</H1>
<H2> Congratulations, ApacheJServ 1.1.2 is working!<br>
</BODY></HTML>
 client:~ % lynx -source http://servername/servlets/Hello
<HTML><HEAD><TITLE>
Example Apache JServ Servlet
</TITLE></HEAD><BODY bgcolor="#FFFFFF">
<H1>Example Apache JServ Servlet</H1>
<H2> Congratulations, ApacheJServ 1.1.2 is working!<br>
</BODY></HTML>
 client:~ % lynx -source http://servername/servlets/Hello
<HTML><HEAD><TITLE>
Example Apache JServ Servlet
</TITLE></HEAD><BODY bgcolor="#FFFFFF">
<H1>Example Apache JServ Servlet</H1>
<H2> Congratulations, ApacheJServ 1.1.2 is working!<br>
</BODY></HTML>
 client:~ % lynx -source http://rmpunix/servlets/Hello
 client:~ % lynx -source http://rmpunix/servlets/Hello
 client:~ % lynx -source http://rmpunix/servlets/Hello
 client:~ % lynx -source http://servername/servlets/Hello
 client:~ %
----End of sample output----

The log files don't shed any light on this.  Here are the relevant log files:
----begin jserv.log----
[30/08/2000 23:08:24:970 GMT] Hello: init
----end jserv.log----

----begin mod_jserv.log----
----end mod_jserv.log

----begin access_log----
10.0.0.1 - - [30/Aug/2000:19:09:29 -0400] "GET /servlets/Hello HTTP/1.0" 200 198
10.0.0.1 - - [30/Aug/2000:19:09:30 -0400] "GET /servlets/Hello HTTP/1.0" 200 198
10.0.0.1 - - [30/Aug/2000:19:09:31 -0400] "GET /servlets/Hello HTTP/1.0" 200 198
10.0.0.1 - - [30/Aug/2000:19:09:32 -0400] "GET /servlets/Hello HTTP/1.0" 200 0
10.0.0.1 - - [30/Aug/2000:19:09:33 -0400] "GET /servlets/Hello HTTP/1.0" 200 0
10.0.0.1 - - [30/Aug/2000:19:09:33 -0400] "GET /servlets/Hello HTTP/1.0" 200 0
10.0.0.1 - - [30/Aug/2000:19:09:35 -0400] "GET /servlets/Hello HTTP/1.0" 200 0
----end access_log----

----begin error_log----
[Wed Aug 30 19:05:45 2000] [notice] Apache/1.3.12 (Unix) ApacheJServ/1.1.2 configured -- resuming
normal operations
... _signalnull() found in existing libs
----end error_log----

----begin output of httpd -V----
235# ./httpd -V
Server version: Apache/1.3.12 (Unix)
Server built:   Aug 15 2000 16:23:58
Server's Module Magic Number: 19990320:7
Server compiled with....
 -D HAVE_MMAP
 -D USE_MMAP_SCOREBOARD
 -D USE_MMAP_FILES
 -D USE_FCNTL_SERIALIZED_ACCEPT
 -D SHARED_CORE
 -D HTTPD_ROOT="/usr/local/apache"
 -D SUEXEC_BIN="/usr/local/apache/bin/suexec"
 -D SHARED_CORE_DIR="/usr/local/apache/libexec"
 -D DEFAULT_PIDLOG="logs/httpd.pid"
 -D DEFAULT_SCOREBOARD="logs/httpd.scoreboard"
 -D DEFAULT_LOCKFILE="logs/httpd.lock"
 -D DEFAULT_XFERLOG="logs/access_log"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D TYPES_CONFIG_FILE="conf/mime.types"
 -D SERVER_CONFIG_FILE="conf/httpd.conf"
 -D ACCESS_CONFIG_FILE="conf/access.conf"
 -D RESOURCE_CONFIG_FILE="conf/srm.conf"
----end output of httpd -V----
>How-To-Repeat:
Vanilla install of Apache 1.3.12 (untar source, type ./configure, make, make install)
Apache JServ 1.1.2 (untar source, ./configure --with-apxs=/usr/local/apache/bin/apxs, make,
make install, modify httpd.conf as instructed to add in jserv/jserv.conf)
>Fix:
no
>Release-Note:
>Audit-Trail:
>Unformatted:
 [In order for any reply to be added to the PR database, you need]
 [to include <apbugs@Apache.Org> in the Cc line and make sure the]
 [subject line starts with the report component and number, with ]
 [or without any 'Re:' prefixes (such as "general/1098:" or      ]
 ["Re: general/1098:").  If the subject doesn't match this       ]
 [pattern, your message will be misfiled and ignored.  The       ]
 ["apbugs" address is not added to the Cc line of messages from  ]
 [the database automatically because of the potential for mail   ]
 [loops.  If you do not include this Cc, your reply may be ig-   ]
 [nored unless you are responding to an explicit request from a  ]
 [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
 
 


Mime
View raw message