www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marco DiPlacido <mdiplac...@yahoo.com>
Subject mod_rewrite/6346: using mod_proxy and mod_rewrite together is broken under this release
Date Fri, 28 Jul 2000 06:29:43 GMT

>Number:         6346
>Category:       mod_rewrite
>Synopsis:       using mod_proxy and mod_rewrite together is broken under this release
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Thu Jul 27 23:30:00 PDT 2000
>Closed-Date:
>Last-Modified:
>Originator:     mdiplacido@yahoo.com
>Release:        1.3.12
>Organization:
apache
>Environment:
FreeBSD mdiplacido.ne.mediaone.net 4.0-RELEASE FreeBSD 4.0-RELEASE #0: Sun Jun 18 22:06:06
EDT 2000     marco@mdiplacido.ne.mediaone.net:/usr/src/sys/compile/ARLINGTON  i386
>Description:
things work fine under 1.3.6   

this config works fine.

RewriteEngine On
RewriteLog "/usr/local/apache/logs/REWRITE_log"
RewriteLogLevel 0
ProxyRequests On
NoCache *

RewriteRule (http:\/\/www\.apache\.com(.*))  http://www.yahoo.com$2 [P]
>How-To-Repeat:
try the above under 1.3.12   
i build both servers the same way
./configure --enable-module=proxy --enable-module=rewrite
>Fix:
it seems that the rewrite engine never get's called using this config under 1.3.12  

if i remove: 
ProxyRequests On
NoCache *

the rewrite engine is envoked but $_ (i'm thinking perl) is now an URI and not an URL the
match will always fail.

is there anything i can do to get this working under 1.3.12?
i've read all the docs and install files.  i've moved around the module install order and
nothing seems to work.   i'll probably just stick with 1.3.6 for now.

no clue on how to fix it!  :)

-marco
>Release-Note:
>Audit-Trail:
>Unformatted:
 [In order for any reply to be added to the PR database, you need]
 [to include <apbugs@Apache.Org> in the Cc line and make sure the]
 [subject line starts with the report component and number, with ]
 [or without any 'Re:' prefixes (such as "general/1098:" or      ]
 ["Re: general/1098:").  If the subject doesn't match this       ]
 [pattern, your message will be misfiled and ignored.  The       ]
 ["apbugs" address is not added to the Cc line of messages from  ]
 [the database automatically because of the potential for mail   ]
 [loops.  If you do not include this Cc, your reply may be ig-   ]
 [nored unless you are responding to an explicit request from a  ]
 [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
 
 


Mime
View raw message