www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wr...@apache.org
Subject Re: build/6214: gethostname() problem
Date Tue, 20 Jun 2000 18:59:22 GMT
[In order for any reply to be added to the PR database, you need]
[to include <apbugs@Apache.Org> in the Cc line and make sure the]
[subject line starts with the report component and number, with ]
[or without any 'Re:' prefixes (such as "general/1098:" or      ]
["Re: general/1098:").  If the subject doesn't match this       ]
[pattern, your message will be misfiled and ignored.  The       ]
["apbugs" address is not added to the Cc line of messages from  ]
[the database automatically because of the potential for mail   ]
[loops.  If you do not include this Cc, your reply may be ig-   ]
[nored unless you are responding to an explicit request from a  ]
[developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]


Synopsis: gethostname() problem

State-Changed-From-To: open-feedback
State-Changed-By: wrowe
State-Changed-When: Tue Jun 20 11:59:13 PDT 2000
State-Changed-Why:

First off, setting the ServerName directive properly is
effectively manditory, any coincidental success without
this directive is your own blind luck.

We have addressed the issue where gethostname returns no
fqdn (dotted notation) by substituting the ip address in
the forthcoming Apache 1.3.13 release.  I will apply the
same fix to the 2.0b5-dev tree and see where that gets us.

Please try 2.0b5-dev upon it's release, and let us know
if you succeed in running that server without the ServerName
directive.

We aren't implying you shouldn't set it, but we want to
assure that Apache recovers somewhat gracefully.

Thanks for your report and interest in the 2.0 alpha!

Class-Changed-From-To: sw-bug-support
Class-Changed-By: wrowe
Class-Changed-When: Tue Jun 20 11:59:13 PDT 2000


Mime
View raw message