www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roland Windfelder <roland_windfel...@sepp.de>
Subject general/5990: Hostnames with underscore fail to work
Date Fri, 14 Apr 2000 07:24:07 GMT

>Number:         5990
>Category:       general
>Synopsis:       Hostnames with underscore fail to work
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Fri Apr 14 00:30:00 PDT 2000
>Closed-Date:
>Last-Modified:
>Originator:     roland_windfelder@sepp.de
>Release:        1.3.11
>Organization:
apache
>Environment:
Linux 2.2, WinNT 4.0 ..., likely all platforms
>Description:
With apache 1.3.11 and later underscore in ServerName doesn't work.

With apache 1.3.9 and lower it works fine.

I get the error Message:
  Bad Request
  Your browser sent a request that this server could not understand
  Client sent malformed Host header

Any suggestion?

Same problem was reported on 8. February (Nr. 5722), but no response
>How-To-Repeat:
Apache Configuration with underscore in servername

...
ServerName server_1
...
>Fix:

>Release-Note:
>Audit-Trail:
>Unformatted:
 [In order for any reply to be added to the PR database, you need]
 [to include <apbugs@Apache.Org> in the Cc line and make sure the]
 [subject line starts with the report component and number, with ]
 [or without any 'Re:' prefixes (such as "general/1098:" or      ]
 ["Re: general/1098:").  If the subject doesn't match this       ]
 [pattern, your message will be misfiled and ignored.  The       ]
 ["apbugs" address is not added to the Cc line of messages from  ]
 [the database automatically because of the potential for mail   ]
 [loops.  If you do not include this Cc, your reply may be ig-   ]
 [nored unless you are responding to an explicit request from a  ]
 [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
 
 


Mime
View raw message