www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzilla-dae...@locus.apache.org
Subject [Bug 38] New - Path info on cgi request returns Forbidden
Date Wed, 05 Apr 2000 20:51:21 GMT
http://www.apache.org/bugs/show_bug.cgi?id=38

*** shadow/38	Wed Apr  5 13:51:21 2000
--- shadow/38.tmp.85470	Wed Apr  5 13:51:21 2000
***************
*** 0 ****
--- 1,35 ----
+ Bug#: 38
+ Product: httpd
+ Version: 2.0a
+ Platform: PC
+ OS/Version: 
+ Status: NEW   
+ Resolution: 
+ Severity: serious
+ Priority: medium
+ Component: mod_cgi
+ AssignedTo: apache@apache.org                            
+ ReportedBy: Jim.Patterson@Cognos.COM               
+ URL: 
+ Summary: Path info on cgi request returns Forbidden
+ 
+ I am a developer of a web query tool and have taken on the task of ensuring that 
+ our tool works with Apache. Apache 1.3 works quite well with our product. 
+ However, when I run our product with 2.0a2 (or 2.0a1) I get the error page below 
+ instead of a page from our product. It appears that the extra path info is 
+ causing the difference in behaviour, but I have no direct evidence of this 
+ other than this message. The part of the url up to cqcgi.exe is the path to our 
+ CGI gateway application, and everything that follows should come through as 
+ PATH_INFO. The virtual path /cognos/cgi-bin is defined as a ScriptAlias 
+ directory in my httpd.conf file. Another URL that precedes this one and which 
+ does not have extra path information works correctly.
+ 
+ *************
+ Forbidden
+ 
+ You don't have permission to access 
+ /cognos/cgi-bin/cqcgi.exe/x3_3aGreat_20Outdoors_2eDefault_20Package/script/repor
+ t.iws on this server.
+ 
+ 
+ Apache/2.0a2 Server at wsfrpattersj Port 80

Mime
View raw message