www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thierry Delaitre <dela...@cpc.wmin.ac.uk>
Subject Re: mod_jserv/5420: Segmentation Fault
Date Sat, 19 Feb 2000 22:50:01 GMT
The following reply was made to PR mod_jserv/5420; it has been noted by GNATS.

From: Thierry Delaitre <delaitt@cpc.wmin.ac.uk>
To: Ed Korthof <ed@cloudfactory.org>
Cc: apbugs@hyperreal.org
Subject: Re: mod_jserv/5420: Segmentation Fault
Date: Sat, 19 Feb 2000 22:42:27 +0000 (GMT)

 I found a solution to this problem in PR#4645. There seems to be a Solaris
 7 patch to fix this problem. I've managed to get DSO working on Solaris 7
 11/99 which includes this patch. 
 
 Thierry.
 
 On Fri, 10 Dec 1999, Ed Korthof wrote:
 
 > ok ... well, we're closer.  there's a problem either before or at the
 > point when the module is loaded as a DSO -- before any JServ code has run. 
 > given that, it seems unlikely that JServ is the source of your problem --
 > unless the problem is our compiler options.  can you compile and use any
 > other DSOs?  can you start the webserver if you compile JServ in
 > statically? 
 > 
 > when you compile or load JServ, do you see any warnings about relocatable
 > code?  you could try adding -fpic or -fPIC to your CFLAGS -- if one or the
 > other isn't not already there, and it solves the problem, it's something
 > we should look into adding (dep on system and/or compiler).  (pic stands
 > for position independant code; from the man pages, the main difference
 > seems to be that -fPIC is more insistent about it.)
 > 
 > thanks --
 > 
 > ed
 

Mime
View raw message